HDU1392--Surround the Trees--凸包

Description

There are a lot of trees in an area. A peasant wants to buy a rope to surround all these trees. So at first he must know the minimal required length of the rope. However, he does not know how to calculate it. Can you help him?  
The diameter and length of the trees are omitted, which means a tree can be seen as a point. The thickness of the rope is also omitted which means a rope can be seen as a line.



There are no more than 100 trees.
 

Input

The input contains one or more data sets. At first line of each input data set is number of trees in this data set, it is followed by series of coordinates of the trees. Each coordinate is a positive integer pair, and each integer is less than 32767. Each pair is separated by blank.

Zero at line for number of trees terminates the input for your program.
 

Output

The minimal length of the rope. The precision should be 10^-2.
 

Sample Input

    
    
9 12 7 24 9 30 5 41 9 80 7 50 87 22 9 45 1 50 7 0
 

Sample Output

    
    
243.06
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <iomanip>
using namespace std;
struct Point
{
	int x,y;
}point[108],res[108];
bool cmp(Point a,Point b)
{
	if(a.x>b.x)return 0;
	else if(a.x==b.x)return a.y>b.y?0:1;
	return 1;
}
bool ral(Point p1,Point p2,Point p3)
{
	return ((p3.y-p1.y)*(p2.x-p1.x)>(p2.y-p1.y)*(p3.x-p1.x));
}
double distant(Point a,Point b)
{
	return sqrt(double((b.y-a.y)*(b.y-a.y)+(b.x-a.x)*(b.x-a.x)));
}
int main()
{
	int n;
	while(cin>>n&&n)
	{
		for(int i=0;i<n;i++)
		{
			cin>>point[i].x>>point[i].y;
		}
		if(n==1)
		{
			cout<<0.00<<endl;
			continue;
		}
		if(n==2)
		{
			double len1=sqrt(double(point[1].y-point[0].y)*(point[1].y-point[0].y)+(point[1].x-point[0].x)*(point[1].x-point[0].x));
			cout<<setiosflags(ios::fixed)<<setprecision(2)<<len1<<endl;
			continue;
		}
		sort(point,point+n,cmp);
		int m=-1;
		for(int i=0;i<n;i++)
		{
			while(m>=1&&!ral(res[m-1],res[m],point[i]))
			{
				m--;
			}
			res[++m]=point[i];
		}
		int k=m;
		for(int i=n-2;i>=0;i--)
		{
			while(m>k&&!ral(res[m-1],res[m],point[i]))
			{
				m--;
			}
			res[++m]=point[i];
		}
		double len=0;
		for(int i=0;i<m;i++)
		{
			len+=distant(res[i],res[i+1]);
		}
		cout<<setiosflags(ios::fixed)<<setprecision(2)<<len<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园建设方案旨在通过信息化手段提升教育、管理和服务水平,实现资源数字化、工作流程化、管理高效化和决策智能化。方案包括智慧校园信息化平台和安防平台的建设,涉及教学、科研、管理和服务等多个方面,以满足现代教育和培训需求。 技术服务要求强调了统一支撑平台的建设,包括数据标准、接口标准、代码标准和用户信息标准的统一制定。平台需满足信创和X86交叉适配要求,确保安全自主可控的系统开发环境。此外,方案还涵盖了用户中心系统、统一认证授权中心、统一工作流中心、统一智能报表中心等多个模块,以及数据共享中心、语音识别、移动服务终端等功能,以实现校园内外部信息的互联互通和资源共享。 智慧校园信息化平台的建设还包括了对教学管理、人事管理、公文管理、档案管理、即时通讯、会议管理、督办工作、资产管理等方面的数字化和自动化升级。这些模块的集成旨在提高工作效率,优化资源配置,加强监督管理,并通过移动应用等技术手段,实现随时随地的信息访问和业务处理。 安防平台的建设则侧重于校园安全,包括停车场管理、人脸识别测温、访客自助登记、视频监控等多个系统。这些系统的集成旨在提高校园的安全管理水平,实现对校园内外人员和车辆的有效监控和管理,确保校园环境的安全稳定。 最后,方案还提到了对固定资产的管理,包括购置、使用、归还、报废等全生命周期的管理,以及对网络设备、安防设备、服务器等硬件设施的配置和管理。通过这些措施,智慧校园建设方案旨在为校园提供一个安全、高效、便捷的学习和工作环境。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值