POJ3083--Children of the Candy Corn

Description

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit.  

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there's no guarantee which strategy (left or right) will be better, and the path taken is seldom the most efficient. (It also doesn't work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.)  

As the proprieter of a cornfield that is about to be converted into a maze, you'd like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding visitors.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze layout. Walls are represented by hash marks ('#'), empty space by periods ('.'), the start by an 'S' and the exit by an 'E'.  

Exactly one 'S' and one 'E' will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls ('#'), with the only openings being the 'S' and 'E'. The 'S' and 'E' will also be separated by at least one wall ('#').  

You may assume that the maze exit is always reachable from the start point.

Output

For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the 'S' and 'E') for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.

Sample Input

2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output

37 5 5
17 17 9
/*
先输入列数,再输入行数
此题要做两边,先做向左,再做向右。。这个要用dfs实现
在找最短路的时候,要用BFS实现
巨坑。。我在右搜的递归递了左搜的函数。。debug了我1个多小时。。。。。
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
using namespace std;
int c,r,tr,tc;
bool map[48][48];
int heng[]={0,0,-1,1};
int zong[]={1,-1,0,0};
#define inf 0x3f3f3f3f
//地图的宽和高的上限都是40
int cleft,cright;
int cost[48][48];
void dfs_le(int r1,int c1,int d)
{
	cleft++;
	if(r1==tr&&c1==tc)
	{
		return;
	}
	switch(d)
	{
		case 0:
		{
			if(map[r1][c1-1])
			{
				dfs_le(r1,c1-1,1);
			}
			else if(map[r1-1][c1])
			{
				dfs_le(r1-1,c1,0);
			}
			else if(map[r1][c1+1])
			{
				dfs_le(r1,c1+1,3);
			}
			else if(map[r1+1][c1])
			{
				dfs_le(r1+1,c1,2);
			}
			break;
		}
		case 1:
		{
			if(map[r1+1][c1])
			{
				dfs_le(r1+1,c1,2);
			}
			else if(map[r1][c1-1])
			{
				dfs_le(r1,c1-1,1);
			}
			else if(map[r1-1][c1])
			{
				dfs_le(r1-1,c1,0);
			}
			else if(map[r1][c1+1])
			{
				dfs_le(r1,c1+1,3);
			}
			break;
		}
		case 2:
		{
			if(map[r1][c1+1])
			{
				dfs_le(r1,c1+1,3);
			}
			else if(map[r1+1][c1])
			{
				dfs_le(r1+1,c1,2);
			}
			else if(map[r1][c1-1])
			{
				dfs_le(r1,c1-1,1);
			}
			else if(map[r1-1][c1])
			{
				dfs_le(r1-1,c1,0);
			}
			break;
		}
		case 3:
		{
			if(map[r1-1][c1])
			{
				dfs_le(r1-1,c1,0);
			}
			else if(map[r1][c1+1])
			{
				dfs_le(r1,c1+1,3);
			}
			else if(map[r1+1][c1])
			{
				dfs_le(r1+1,c1,2);
			}
			else if(map[r1][c1-1])
			{
				dfs_le(r1,c1-1,1);
			}
			break;
		}
	}
}
void dfs_ri(int r1,int c1,int d)
{
	cright++;
	if(tr==r1&&tc==c1)
	{
		return;
	}
	switch(d)
	{
		case 0:
		{
			if(map[r1][c1+1])
			{
				dfs_ri(r1,c1+1,3);
			}
			else if(map[r1-1][c1])
			{
				dfs_ri(r1-1,c1,0);
			}
			else if(map[r1][c1-1])
			{
				dfs_ri(r1,c1-1,1);
			}
			else if(map[r1+1][c1])
			{
				dfs_ri(r1+1,c1,2);
			}
			break;
		}
		case 1:
		{
			if(map[r1-1][c1])
			{
				dfs_ri(r1-1,c1,0);
			}
			else if(map[r1][c1-1])
			{
				dfs_ri(r1,c1-1,1);
			}
			else if(map[r1+1][c1])
			{
				dfs_ri(r1+1,c1,2);
			}
			else if(map[r1][c1+1])
			{
				dfs_ri(r1,c1+1,3);
			}
			break;
		}
		case 2:
		{
			if(map[r1][c1-1])
			{
				dfs_ri(r1,c1-1,1);
			}
			else if(map[r1+1][c1])
			{
				dfs_ri(r1+1,c1,2);
			}
			else if(map[r1][c1+1])
			{
				dfs_ri(r1,c1+1,3);
			}
			else if(map[r1-1][c1])
			{
				dfs_ri(r1-1,c1,0);
			}
			break;
		}
		case 3:
		{
			if(map[r1+1][c1])
			{
				dfs_ri(r1+1,c1,2);
			}
			else if(map[r1][c1+1])
			{
				dfs_ri(r1,c1+1,3);
			}
			else if(map[r1-1][c1])
			{
				dfs_ri(r1-1,c1,0);
			}
			else if(map[r1][c1-1])
			{
				dfs_ri(r1,c1-1,1);
			}
			break;
		}
	}	
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		cleft=cright=0;
		memset(cost,0x3f,sizeof(cost));
		memset(map,0,sizeof(map));
		scanf("%d%d",&c,&r);
		getchar();
		int sr,sc;
		for(int i=1;i<=r;i++)
		{
			for(int j=1;j<=c;j++)
			{
				char cc=getchar();
				map[i][j]='#'!=cc?1:0;
				if(cc=='S')
				{
					sr=i;sc=j;
				}
				if(cc=='E')
				{
					tr=i;tc=j;
				}
			}
			getchar();
		}
		int d;
		if(sr==1)d=2;
		if(sr==r)d=0;
		if(sc==1)d=3;
		if(sc==c)d=1;
		dfs_le(sr,sc,d);
		dfs_ri(sr,sc,d);
		queue <int> qr;
		queue <int> qc;
		qr.push(sr);
		qc.push(sc);
		cost[sr][sc]=0;
		while(!qr.empty())
		{
			int r_=qr.front();
			int c_=qc.front();
			if(r_==tr&&c_==tc)break;
			qr.pop();qc.pop();
			for(int i=0;i<4;i++)
			{
				int r__=r_+heng[i];
				int c__=c_+zong[i];
				if((r__>=1&&r__<=r)&&(c__>=1&&c__<=c)&&(map[r__][c__]&&cost[r_][c_]+1<cost[r__][c__]))
				{
					cost[r__][c__]=cost[r_][c_]+1;
					qr.push(r__);
					qc.push(c__);
				}
			}
		}
		printf("%d %d %d\n",cleft,cright,cost[tr][tc]+1);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值