game--博弈

Description

The Little Girl loves problems on games very much. Here's one of them.

Two players have got a string s, consisting of lowercase English letters. They play a game that is described by the following rules:

1.The players move in turns; In one move the player can remove an arbitrary letter from string s.

2. If the player before his turn can reorder the letters in string s so as to get a palindrome, this player wins.

A palindrome is a string that reads the same both ways (from left to right, and vice versa). For

example, string "abba" is a palindrome and string "abc" isn't.

Determine which player will win, provided that both sides play optimally well — the one who moves first or the one who moves second.


Input Description
There are multiple cases ended by EOF. Each case containing a string s (1 ≤ |s|  ≤  10^3). String s consists of lowercase English letters.
Output Description
For each case , In a single line print word "First" if the first player wins (provided that both players play optimally well). Otherwise, print word "Second". Print the words without the quotes.
Sample Input
aba
abca
Sample Output
First
Second
/*
此题很简单。首先是第一个人,如果第一个能把整理为回文串。游戏结束
如果不行,游戏必然会进行到剩下一个字母。。对方不可能留全是出现偶数的字母给你吧?也不可能留只有一个字母出现奇数的给你吧?
肯定是阴来阴去。
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;
char A[88];
int AA[28];
int main()
{
	while(cin>>A)
	{
		memset(AA,0,sizeof(AA));
		int len=strlen(A);
		for(int i=0;i<len;i++)
		{
			AA[A[i]-'a']++;
		}
		int fuck=0;
		for(int i=0;i<26;i++)
		{
			if(AA[i]%2)fuck++;
		}
		if(fuck==1||!fuck||len%2)
		{
			printf("First\n");
		}
		else printf("Second\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值