Discrete Speed--最短路

Constraints

Time Limit: 2 secs, Memory Limit: 256 MB , Special Judge

Description

Consider car trips in a country where there is no friction. Cars in this country do not have engines. Once a car started to move at a speed, it keeps moving at the same speed. There are acceleration devices on some points on the road, where a car can increase or decrease its speed by 1. It can also keep its speed there. Your job in this problem is to write a program which determines the route with the shortest time to travel from a starting city to a goal city.

There are several cities in the country, and a road network connecting them. Each city has an acceleration device. As mentioned above, if a car arrives at a city at a speed v , it leaves the city at one of v - 1, v , or v + 1. The first road leaving the starting city must be run at the speed 1. Similarly, the last road arriving at the goal city must be run at the speed 1.

The starting city and the goal city are given. The problem is to find the best route which leads to the goal city going through several cities on the road network. When the car arrives at a city, it cannot immediately go back the road it used to reach the city. No U-turns are allowed. Except this constraint, one can choose any route on the road network. It is allowed to visit the same city or use the same road multiple times. The starting city and the goal city may be visited during the trip.

For each road on the network, its distance and speed limit are given. A car must run a road at a speed less than or equal to its speed limit. The time needed to run a road is the distance divided by the speed. The time needed within cities including that for acceleration or deceleration should be ignored.

Input

The input consists of multiple datasets, each in the following format.

n m
s g
x
1 y 1 d 1 c 1
...
xm ym dm cm

Every input item in a dataset is a non-negative integer. Input items in the same line are separated by a space.

The first line gives the size of the road network. n is the number of cities in the network. You can assume that the number of cities is between 2 and 30, inclusive. m is the number of roads between cities, which may be zero.

The second line gives the trip. s is the city index of the starting city. g is the city index of the goal city. s is not equal to g . You can assume that all city indices in a dataset (including the above two) are between 1 and n , inclusive.

The following m lines give the details of roads between cities. The i -th road connects two cities with city indices xi and yi , and has a distance di (1 ≤ i m ). You can assume that the distance is between 1 and 100, inclusive. The speed limit of the road is specified by ci . You can assume that the speed limit is between 1 and 30, inclusive.

No two roads connect the same pair of cities. A road never connects a city with itself. Each road can be traveled in both directions.

The last dataset is followed by a line containing two zeros (separated by a space).

Output

For each dataset in the input, one line should be output as specified below. An output line should not contain extra characters such as spaces.

If one can travel from the starting city to the goal city, the time needed for the best route (a route with the shortest time) should be printed. The answer should not have an error greater than 0.001. You may output any number of digits after the decimal point, provided that the above accuracy condition is satisfied.

If it is impossible to reach the goal city, the string "unreachable" should be printed. Note that all the letters of "unreachable" are in lowercase.

Sample Input

2 0
1 2
5 4
1 5
1 2 1 1
2 3 2 2
3 4 2 2
4 5 1 1
6 6
1 6
1 2 2 1
2 3 2 1
3 6 2 1
1 4 2 30
4 5 3 30
5 6 2 30
6 7
1 6
1 2 1 30
2 3 1 30
3 1 1 30
3 4 100 30
4 5 1 30
5 6 1 30
6 4 1 30
0 0

Sample Output

unreachable4.000005.5000011.25664

奇葩。。既然第一个测试数据就WA???到底错在哪里啊啊啊啊啊

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
#include <string>
#include <cmath>
using namespace std;
bool map[38][38];//用来存路数
double dis[38][38];
int limit[38][38];
int cel[]={-1,0,1};
double stim[38][38];//以某个速度到达这个城市的最短时间,用来剪枝(和路的限制,速度降为0等一同发挥作用)
//现在唯一的问题就是不能用刚用过得路。
int main()
{
    int n,m;//n是城市数目,m是路的数目,城市是从1到n进行标号的
    while(scanf("%d%d",&n,&m)==2&&(n||m))
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<=35;j++)
            {
                stim[i][j]=999999.0;//以速度j到达城市i的最短时间
            }
        }
        int s,g;
        memset(map,0,sizeof(map));//初始化没问题
        scanf("%d%d",&s,&g);//输入起点和终点,注意起点的速度是1,到达终点的速度必须也是1
        int u,v,c;
        double d;
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%lf%d",&u,&v,&d,&c);
            map[u][v]=1;
            dis[u][v]=d;
            limit[u][v]=c;
            map[v][u]=1;
            dis[v][u]=d;
            limit[v][u]=c;
        }//路存完毕
        queue <int> qc;//用来存城市
        queue <int> qv;//用来存速度
        queue <int> qyuan;
        qc.push(s);
        qv.push(0);
        qyuan.push(s);
        stim[s][0]=0.;
        while(!qc.empty())//这里还有个问题,离开第一做城市的速度必须是1
        {
            int nc=qc.front();
            int nv=qv.front();
            int nyuan=qyuan.front();
            qc.pop();qv.pop();qyuan.pop();
            for(int i=0;i<3;i++)
            {
                int v_=nv+cel[i];
                if(v_>0)//如果速度不为0,接下来得考虑速度的上限问题
                {
                    for(int j=1;j<=n;j++)
                    {
                        if(j==nyuan)continue;
                        if(map[nc][j]&&v_<=limit[nc][j])//如果这条路可以走且速度在限制范围内
                        {
                            if(stim[nc][nv]+dis[nc][j]/v_<stim[j][v_])//这里应该用无穷小量,等下注意一下
                            {
                                stim[j][v_]=stim[nc][nv]+dis[nc][j]/v_;
                                qc.push(j);
                                qv.push(v_);
                                qyuan.push(nc);
                            }
                        }
                    }
                }
			}
        }
        if(stim[g][1]!=999999.0)
        {
            printf("%.5lf\n",stim[g][1]);
        }
        else cout<<"unreachable"<<endl;
    }
    return 0;
}         


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值