HDU1381--Crazy Search

Problem Description
Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.

Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa", "aab", "aba", "bab", "bac". Therefore, the answer should be 5.

Input
The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output
The program should output just an integer corresponding to the number of different substrings of size N found in the given text.
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Sample Input
  
  
1 3 4 daababac

Sample Output
5
#include <iostream>
#include <cstdio>
#include <vector>
#include <string>
using namespace std;
struct Word
{
	int key;
	bool flag;
}word;
char str[16000008];
vector <int> ans[119999];
int Hasha(char * s)
{
	int len=strlen(s);
	int ans=0;
	for(int i=0;i<len;i++)
	{
		ans=(ans*307+s[i])%99991;
	}
	return ans;
}
int Hashb(char * s)
{
	int len=strlen(s);
	int ans=0;
	for(int i=0;i<len;i++)
	{
		ans=(ans*293+s[i])%4999963;
	}
	return ans;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int sum=0;
		for(int i=0;i<=100000;i++)
		{
			ans[i].clear();
		}
		int m,n;//每m个作为一个单词,有n个不同的字母
		scanf("%d%d",&m,&n);
		string a;
		cin>>a;
		int len=a.size();
		for(int i=0;i<=len-m;i++)
		{
			
			int k=i;
			for(int j=0;j<m;j++)
			{
				str[j]=a[k++];
			}
			str[m]='\0';
			int key1=Hasha(str);
			int key2=Hashb(str);
			bool flag=false;
			if(ans[key1].size())
			{
				for(int j=0;j<ans[key1].size();j++)
				{
					if(key2==ans[key1][j])
					{
						flag=true;
						break;
					}
				}	
			}
			if((!flag)||(!ans[key1].size()))
			{
				ans[key1].push_back(key2);
				sum++;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}


这个是STL、、

#include <iostream>
#include <cstdio>
#include <string>
#include <set>
using namespace std;
set <string> coll;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		coll.clear();
		int m,n;//每m个在一起,n个是出现的不同字符的种数
		scanf("%d%d",&m,&n);
		string A;
		cin>>A;
		int len=A.size();
		for(int i=0;i<=len-m;i++)
		{
			string a;
			a.resize(m);
			int k=i;
			for(int j=0;j<m;j++)
			{
				a[j]=A[k++];
			}
			coll.insert(a);
		}
		printf("%d\n",coll.size());
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值