HDU1496--Equations

Problem Description
Consider equations having the following form:

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.

Output
For each test case, output a single line containing the number of the solutions.

Sample Input
  
  
1 2 3 -4 1 1 1 1

Sample Output
39088
0

 

将方程拆成两边~

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 2000008
int vis[maxn];
int main()
{
	int a,b,c,d;
	while(scanf("%d%d%d%d",&a,&b,&c,&d)==4)
	{
		if ((a>0 && b>0 && c>0 && d>0) || (a<0 && b<0 && c<0 && d<0))
		{ //没有此优化,会超时
			printf("0\n");
			continue;
		}
		memset(vis,0,sizeof(vis));
		for(int x1=-100;x1<=100;x1++)
		{
			if(!x1)continue;
			for(int x2=-100;x2<=100;x2++)
			{
				if(!x2)continue;
				vis[a*x1*x1+b*x2*x2+1000000]++;
			}
		}
		int sum=0;
		for(int x3=-100;x3<=100;x3++)
		{
			if(!x3)continue;
			for(int x4=-100;x4<=100;x4++)
			{
				if(!x4)continue;
				sum+=vis[1000000-(c*x3*x3+d*x4*x4)];
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值