PAT-A 1064. Complete Binary Search Tree (30)

  1. Complete Binary Search Tree (30)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4

输出要求:层序遍历输出,即按二叉树的编号规则,从1号结点输出到n号

重要性质
1. 二叉查找树的中序遍历是递增序列
2. 完全二叉树 i结点 的左孩子为 2i,右孩子为 2i+1

故先将结点数据排序,得到递增序列,其实就是中序遍历序列,利用中序遍历建立二叉树,这样每次建立的结点就是按着中序遍历序列按顺序取来的。
因为是按编号输出,用顺序结构存储即可

#include <stdio.h>
#include <algorithm>
#define MAXN 1001
using namespace std;


int a[MAXN];
int tree[MAXN];
int n,pos;
void input(){
    scanf("%d", &n);
    for(int i=0; i<n; i++)
        scanf("%d", &a[i]);
    pos=0;
    sort(a,a+n);

}

//完全二叉查找树的中序遍历是递增序列
//中序遍历建立完全二叉树,并利用完全二叉树的性质
void InOrderGenerate(int root){

    if( root <= n){
        //i结点的左孩子为2i,右孩子为2i+1
        int lchild = root << 1;
        int rchild = (root << 1) +1;


        InOrderGenerate(lchild);
        tree[root] = a[pos++];
        InOrderGenerate(rchild);
    }
}

int main(){

    input();


    InOrderGenerate(1);

    for(int i=1; i<n; i++)
        printf("%d ", tree[i]);
    printf("%d\n", tree[n]);

    return 0;
}

总结:对二叉查找树和完全二叉树的性质有了更深刻的理解。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值