zoj 3726

Alice's Print Service

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money.

For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It's easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.

Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.

Input

The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.

Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 105). The second line contains 2n integers s1, p1, s2, p2, ..., sn, pn (0=s1 < s2 < ... < sn ≤ 109, 109 ≥ p1 ≥ p2 ≥ ... ≥ pn ≥ 0). The price when printing no less than si but less than si+1 pages is pi cents per page (for i=1..n-1). The price when printing no less than sn pages is pn cents per page. The third line containing m integers q1 .. qm (0 ≤ qi ≤ 109) are the queries.

Output

For each query qi, you should output the minimum amount of money (in cents) to pay if you want to print qi pages, one output in one line.

Sample Input
1
2 3
0 20 100 10
0 99 100
Sample Output
0
1000
1000

题意:给出n种方案,当要购买的量达到si以上时,可用每件pi的价格购买。例如要购买99件物品,给出的方案是购买0件以上每件20和购买100件以上每件10,显然是多购买一件的方案才可以使开销最小。

思路:假设购买num件,一开始我以为只要二分找到一个最接近num但比num小或等于的s.i,若s.i对应的价格是p.i,答案必然是min(num*p.i,s.i+1*p.i+1)。但后来发现有这么一种情况样例,无论够买什么答案都是0,这让我想到后面的可能比前面的小,所以一开始就对数据进行预处理,从后往前推,存放s.i后面的所有s.i*p.i的最小值,答案必定就是这个值跟num*p.i之一

1

5 5

0 20 100 15 200 10 300 5 500 0

0 100 200 300 500


#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct sw{
	long long s,p;
}E[100005];
long long dp[100005];
long long min(long long a,long long b){
	return (a<b?a:b);
}
int main(void){
	int n,m,T;
	long long num,ans,ans1,ans2;
	scanf("%d",&T);
	while(T--){
		scanf("%d%d",&n,&m);
		for(int i=0;i<n;i++)
			scanf("%lld%lld",&E[i].s,&E[i].p);
		dp[n-1]=E[n-1].s*E[n-1].p;
		for(int i=n-2;i>=0;i--)
			dp[i]=min(E[i].s*E[i].p,dp[i+1]);
		while(m--){
			scanf("%lld",&num);
			int l,r,mid;
			l=0,r=n-1;
			while(l<r){
				mid=(l+r+1)/2;
				if(num>=E[mid].s)
					l=mid;
				else r=mid-1;
			}
		 	ans1=num*E[l].p;
			if(l==n-1) ans2=ans1;
			else ans2=dp[l+1];
			ans=min(ans1,ans2);
			printf("%lld\n",ans);
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值