a1004. Counting Leaves (30)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output

0 1


这题值得好好总结一下,因为花了好长时间(早上9点到下午3点)才想出自己的问题所在。题目说输入m行非叶子节点的子节点,01为根节点,我便以为接下来都是按02,03,04的顺序输入各节点,因此直接用level=父节点的level+1,但是如果不是从01开始输的话,非根节点作为第一行输入的时候层数也为0了。

因此根据此题总结,求层数还是按BFS或递归DFS求。

附上很烂的AC代码待改进:

#include <iostream>
#include <vector>
#include <queue>
using namespace std;
struct Node{
  int id;
  int level;
  vector<Node*> child;
}node[105];

int n,m,maxl=0;
int cnt[105];

queue<Node> q;
void bfs(int  i){
  q.push(node[i]);
  node[i].level=0;
  Node temp;
  while(!q.empty()){
    temp=q.front();
    q.pop();
    maxl=max(maxl,temp.level);
    if(temp.child.empty()) cnt[temp.level]++;
    for(int j=0;j<temp.child.size();j++){
     temp.child[j]->level=temp.level+1;
       q.push(*(temp.child[j]));
    }
    
  }
}
bool noleaves[105];
int main(){
 // freopen("D:\input.txt","r",stdin);

  int k,ID;
  cin>>n>>m;
  
  while(m--){
    cin>>ID>>k;
    node[ID].id=ID;
    noleaves[ID]=true;
    while(k--){
      int tmp;
      cin>>tmp;
      node[tmp].id=tmp;
      //node[tmp].level=node[ID].level+1; //开始试图这样求层数,犯了默认按出现顺序输层数的错误
     // if(node[tmp].level>max) max=node[tmp].level;
      node[ID].child.push_back(&node[tmp]);  
    }
  }
  

  bfs(1);

  for(int i=0;i<=maxl;i++){
    cout<<cnt[i];
    if(i!=maxl) cout<<" ";
  }
  cout<<endl;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值