算术基本运算

算术基本运算

Time Limit: 1 Sec  Memory Limit: 2 MB
Submit: 24686  Solved: 7328
[Submit][Status][Web Board]

Description

计算两整数x和y(0<x,y<1000)的和、差、积、商、余数、x的平方和y的三次方。

Input

输入只有一行,格式见sample。

Output

输出为多行,按顺序每行输出x,y的和、差、积、商、余数、x的平方和y的三次方,格式见sample

Sample Input

x = 11, y = 3

Sample Output

x + y : 14

x - y : 8

x * y : 33

x / y quotient: 3, remainder: 2

 x ^ 2 : 121

 y ^ 3 : 27

HINT

注意输入输出格式。了解C语言整数除法运算符的特点,并且没有求幂的运算符。

Append Code



代码:

#include<stdio.h>
int main()
{
    int a,b;
    scanf("x = %d, y = %d",&a,&b);
    printf("x + y : %d\n",a+b);
    printf("x - y : %d\n",a-b);
    printf("x * y : %d\n",a*b);
    printf("x / y quotient: %d, remainder: %d\n",a/b,a%b);
    printf("x ^ 2 : %d\n",a*a);
    printf("y ^ 3 : %d\n",b*b*b);
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值