POJ1050-To the Max

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 48010 Accepted: 25395

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source


题意:在一个方阵中求最大的子矩阵

解题思路:

先复习一下最大子序列和:用dp[i]表示以第i个数为结尾的子序列和最大值,状态转移方程:
dp[i]=a[i] (dp[i-1]<0)
dp[i]=dp[i-1]+a[i] (dp[i-1]>=0)
求最大子矩阵和的时候,就是取出两行i,j,把这两行之间同一列的都加起来形成另外一个数组,求这个数组的最大子段和,求出来的这个和,就是这两行之间高度为i-j的子矩阵中最大的和。


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;

#define LL long long

int n,a[105][105],x[105];

int solve()
{
    int ma=-200,sum=0;
    for(int i=1;i<=n;i++)
    {
        if(sum>=0) sum+=x[i];
        else sum=x[i];
        ma=max(ma,sum);
    }
    return ma;
}

int main()
{
    while(~scanf("%d",&n))
    {
        int ma=-200;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
                scanf("%d",&a[i][j]);
        }
        for(int i=1;i<=n;i++)
        {
            memset(x,0,sizeof x);
            for(int j=i;j<=n;j++)
            {
                for(int k=1;k<=n;k++)
                    x[k]+=a[j][k];
                int ans=solve();
                if(ma<ans) ma=ans;
            }
        }
        printf("%d\n",ma);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值