DFS之hdu1045

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4516    Accepted Submission(s): 2568


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
  
  
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 

Sample Output
  
  
5 1 5 2 4
View Code 
 /*
 dfs依次搜索每个点
 */
 #include<iostream>
 #define N 5
 using namespace std;
 
 int map[N][N],ans,m,n;
 bool visited[N][N],flag;
 
 void dfs(int s)
 {
     //当s=n*n时,i=n,j=0,说明路径已经遍历到底
     if(s==n*n)//每一次找到一条路径之后,保存最大碉堡数ans,把所有路径都找完之后,ans就是所能安装的碉堡数
     {
         if(ans<m) ans=m;
         return ;
     }
     int i,j,k;
     i=s/n;j=s%n;
     if(!visited[i][j])
     {
         flag=false;
         if(map[i][j]) flag=true;//如果是x
         for(k=i-1;k>=0&&!flag;k--)//i以上
         {
             if(map[k][j]==1) break;//第一个X以下
             if(visited[k][j]==true)//i以上安装过碉堡
             {
                 flag=true;
                 break;
             }
         }
         for(k=j-1;k>=0&&!flag;k--)//j以左
         {
             if(map[i][k]==1) break;//第一个X以右
             if(visited[i][k]==true)//j以左安装过碉堡
             {
                 flag=true;
                 break;
             }
         }
         if(!flag)//如果(i,j)以上以左都没有安装碉堡,则安装
         {
             m++;//碉堡数加1
             visited[i][j]=true;//该结点访问过
             dfs(s+1);//深度搜索
             m--;//返回父结点
             visited[i][j]=false;//父结点访问标志清除
             dfs(s+1);//
         }
         else
         {
             dfs(s+1);
         }
     }
 }
 
 int main()
 {
     int i,j;
     char t;
     while(cin>>n&&n)
     {
         ans=m=0;
         for(i=0;i<n;i++)
         {
             for(j=0;j<n;j++)
             {
                 cin>>t;
                 map[i][j]=(t=='X');
                 visited[i][j]=false;
             }
         }
         dfs(0);
         cout<<ans<<endl;
     }
     return 0;
 }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值