线段树之Poj3264

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 27508 Accepted: 12918
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0


#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define MAXN 500005
int ma[MAXN];
int mi[MAXN];
//建立线段树
void build(int l,int r,int rt)//左孩子,右孩子,数组下标的索引
{
    if(l==r)
    {
        scanf("%d",&ma[rt]);
        mi[rt]=ma[rt];
        return;
    }
    int m=(l+r)>>1;//取中间数,右移一位相当于除以2
    build(lson);
    build(rson);
    ma[rt]=max(ma[rt<<1],ma[rt<<1|1]);
    mi[rt]=min(mi[rt<<1],mi[rt<<1|1]);
}
//用线段数查找,复杂度logN
int queryma(int L,int R,int l,int r,int rt)
{
    if(L<=l&&R>=r)return ma[rt];//查询边界大于l,r,则返回l,r中最大的
    int m=(l+r)>>1;
    int ret=0;
    if(L<=m)ret=max(ret,queryma(L,R,lson));//选出l,m中在L,R范围中最大的
    if(R>m)ret=max(ret,queryma(L,R,rson));//选出r,m中在L,R范围中最大的
    return ret;
}
int querymi(int L,int R,int l,int r,int rt)
{
    if(L<=l&&R>=r)return mi[rt];
    int m=(l+r)>>1;
    int ret=100000000;
    if(L<=m)ret=min(ret,querymi(L,R,lson));//选出l,m中在L,R范围中最大的
    if(R>m)ret=min(ret,querymi(L,R,rson));
    return ret;
}
int main()
{
    int n,q;
    cin>>n>>q;
    build(1,n,1);
    while(q--)
    {
        int s,e;
        scanf("%d%d",&s,&e);
        printf("%d\n",queryma(s,e,1,n,1)-querymi(s,e,1,n,1));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值