并查集—C - How Many Tables

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4

#include<stdio.h>
int table[1005];
int findtable(int x)
{
    if(table[x]==x) return x;
    else return findtable(table[x]);
}
void join(int x,int y)
{
    int tabx=findtable(x);
    int taby=findtable(y);
    if(tabx!=taby)
        table[tabx]=taby;
}
int main()
{
    int t,a,b,n,m;
    scanf("%d",&t);
    while(t--)
    {
        int sum=0;
        scanf("%d %d",&n,&m);
        for(int i=1; i<=n; i++)
            table[i]=i;
        for(int i=1; i<=m; i++)
        {
            scanf("%d %d",&a,&b);
            join(a,b);
        }
        for(int i=1; i<=n; i++)
        {
            if(table[i]==i)
                sum++;
        }
        printf("%d\n",sum);
    }
    return 0;
}

题目大意:Ignatius要过生日了,邀请了她的好朋友,然而这些好朋友并不是互相认识的。为了避免尴尬,只让认识的朋友坐一桌。问需要多少张桌子。已知如果两个不认识的朋友都认识同一个人,依然可以安排三人同桌(A认识C,B认识C,即认为A认识B)。

思路:这道题是水题了。两种方式来写这个题,一是初始父结点设为本身,这样通过不断更新父结点,查询到父结点为本身的就给一张桌子。二是初始父结点设为-1,这样在不断更新父结点后,查询到父结点为-1的就给一张桌子。其实大同小异啦。看个人爱好吧,我还是比较偏爱设为本身。

提交了7次,样例可以过,但是一直都是wa,我也是很无奈,放了将近一天,又重新看,还是没收获,想哭~只能靠题解了,看了题解之后,不知道该说什么了,我让 i 从 0 开始一直到 n-1 或是 m-1 ,不好意思wa,改成 i 从 1 开始一直到 n 或是 m 就可以 A 了。虽然到现在我还是不知道为什么,但是结果就是 A 了。哪位大佬可以指点一下,是为什么呢? 呃呃,知道为什么了,题目中说了朋友从1开始编号。汗颜|||这大概就是英语渣的后果吧,一些条件会注意不到,读题要仔细仔细仔细。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值