Leagal or Not —— 拓扑排序(王道)

Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 
 
Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

 

Sample Input
 
  
3 2
0 1
1 2
2 2
0 1
1 0
0 0
 
Sample Output
 
  
YES
NO

 

拓扑排序,题意是给出多个人之见的关系,让你判断是否有环。

#include <iostream>
#include<queue>
#include<cstdio>
using namespace std;
vector<int> edge[501];//邻接链表,只需保存与其邻接的节点编号
queue<int> Q;//保存入度为0的节点的队列
int main()
{
    int inDegree[501];//统计每个节点的入度
    int n,m;
    while(scanf("%d %d",&n,&m)!=EOF){
        if(n==0 || m==0)
            break;
        for(int i=0;i<n;i++){//初始化
            inDegree[i]=0;
            edge[i].clear();
        }
        while(m--){
            int a,b;
            scanf("%d %d",&a,&b);
            inDegree[b]++;//b的入度+1
            edge[a].push_back(b);//a的邻接表中添加b
        }
        while(!Q.empty())//清空队列
            Q.pop();
        for(int i=0;i<n;i++){
            if(inDegree[i]==0)//入度为0的放入队列
                Q.push(i);
        }
        int cnt=0;
        while(!Q.empty()){
            int nowP=Q.front();
            Q.pop();
            cnt++;//被确定的节点个数加一
            for(int i=0;i<edge[nowP].size();i++){//将该节点以及以其为弧尾的所有边去除
                inDegree[edge[nowP][i]]--;//该边的入度减一
                if(inDegree[edge[nowP][i]]==0)//该点的入度变为0
                    Q.push(edge[nowP][i]);//把这个点放入队列当中
            }
        }
        puts(cnt==n?"YES":"NO");//所有节点都被确定拓扑序列,原图为有向无环图;否则非有向无环图
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/xym4869/p/8611417.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值