HDU 4403 A very hard Aoshu problem(DFS)

A very hard Aoshu problem

Problem Description
Aoshu is very popular among primary school students. It is mathematics, but much harder than ordinary mathematics for primary school students. Teacher Liu is an Aoshu teacher. He just comes out with a problem to test his students:

Given a serial of digits, you must put a '=' and none or some '+' between these digits and make an equation. Please find out how many equations you can get. For example, if the digits serial is "1212", you can get 2 equations, they are "12=12" and "1+2=1+2". Please note that the digits only include 1 to 9, and every '+' must have a digit on its left side and right side. For example, "+12=12", and "1++1=2" are illegal. Please note that "1+11=12" and "11+1=12" are different equations.
 
Input
There are several test cases. Each test case is a digit serial in a line. The length of a serial is at least 2 and no more than 15. The input ends with a line of "END".
 
Output
For each test case , output a integer in a line, indicating the number of equations you can get.
 
Sample Input
1212 12345666 1235 END
 
Sample Output
2 2 0
 
Answer
先预处理出第i位到第j位的数字是什么(sum数组),然后枚举插入等号的位置(两端不能插入等号),接下来dfs枚举等号左边的情况,每一种情况结束之后,继续dfs枚举等号右边的情况,同时将左边的情况(和)传递过去,等号右边每一种情况结束的时候,对比两个和,如果相等则答案加一。另外,枚举右边的情况的时候,可以加一个剪枝(不加也没事)。
 
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <climits>
#define ms(a) memset(a,0,sizeof a)
using namespace std;
int sum[20][20];
vector<int> v;
string s;
int ans;
//处理等号右边
void dfs2(int lsu,int su,int l)//等号左边的和,和,起点
{
    if(lsu<su)return;
    if(l==(int)s.size()&&lsu==su)
    {
        ans++;
        return;
    }
    for(int i=l+1; i<=(int)s.size(); i++)
    {
        dfs2(lsu,su+sum[l][i-1],i);
    }
}
//处理等号左边
void dfs1(int su,int l,int r)//和,左,右界
{
    if(l==r)
    {
        dfs2(su,0,r);
        return;
    }
    for(int i=l+1; i<=r; i++)
    {
        dfs1(su+sum[l][i-1],i,r);
    }
}
int main()
{
    string::iterator it1,it2;
    while(cin>>s)
    {
        if(s=="END")break;
        //ms(sum);
        ans=0;
        if(s.size()==1)printf("0\n");
        else
        {
            //预处理,得到某个区间的数值
            for(it1=s.begin(); it1!=s.end(); it1++)
            {
                int t=*it1-'0';
                sum[it1-s.begin()][it1-s.begin()]=t;
                for(it2=it1+1; it2!=s.end(); it2++)
                {
                    t=t*10+(*it2-'0');
                    sum[it1-s.begin()][it2-s.begin()]=t;
                }
            }
            //1=234566=6,等号的位置
            for(it1=s.begin()+1; it1!=s.end(); it1++)
            {
                dfs1(0,0,it1-s.begin());
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}
View Code

转载于:https://www.cnblogs.com/gpsx/p/5309166.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值