HDOJ 1211 RSA

Problem Description
RSA is one of the most powerful methods to encrypt data. The RSA algorithm is described as follow:

> choose two large prime integer p, q
> calculate n = p × q, calculate F(n) = (p - 1) × (q - 1)
> choose an integer e(1 < e < F(n)), making gcd(e, F(n)) = 1, e will be the public key
> calculate d, making d × e mod F(n) = 1 mod F(n), and d will be the private key

You can encrypt data with this method :

C = E(m) = m e mod n

When you want to decrypt data, use this method :

M = D(c) = c d mod n

Here, c is an integer ASCII value of a letter of cryptograph and m is an integer ASCII value of a letter of plain text.

Now given p, q, e and some cryptograph, your task is to "translate" the cryptograph into plain text.
 
Input
Each case will begin with four integers p, q, e, l followed by a line of cryptograph. The integers p, q, e, l will be in the range of 32-bit integer. The cryptograph consists of l integers separated by blanks. 
 
Output
For each case, output the plain text in a single line. You may assume that the correct result of plain text are visual ASCII letters, you should output them as visualable letters with no blank between them.
 
Sample Input
  
  
101 103 7 11 7716 7746 7497 126 8486 4708 7746 623 7298 7357 3239
 
Sample Output
  
  
I-LOVE-ACM.
已AC:
#include <iostream>
struct node
{
    int x, y, d;
};
void ExtendGcd(int a, int b, node & s);
bool ModularLinearEquation(int a, int b, int &x, long long n);
long long PowerModular(int a, int b, long long n);

int main()
{
    using namespace std;
    int p, q, e, l;

    while(cin >> p >> q >> e >> l)
    {
        int d;
        long long fn = (p-1)*(q-1);
        long long n = p*q;
        if(ModularLinearEquation(e, 1, d, fn))
            for(int i=0; i<l; ++i)
            {
                int aa;
                cin >> aa;
                cout << (char)PowerModular(aa, d, n);
            }
        cout << endl;
    }
    return 0;
}

void ExtendGcd(int a, int b, node & s)
{
    if(!b)
    {
        s.d = a;
        s.x = 1;
        s.y = 0;
    }
    else
    {
        ExtendGcd(b, a%b, s);
        int temp = s.x;
        s.x = s.y;
        s.y = temp - int(a/b)*s.y;
    }
}

bool ModularLinearEquation(int a, int b, int &x, long long n)
{
    node s;
    ExtendGcd(a, n, s);
    if(b%s.d)
        return false;
    else
        x = b/s.d*s.x;
    x %= n;
    if(x<0)
        x += n;
    return true;
}

long long PowerModular(int a, int b, long long n)
{
    int bb[30] = {0};
    int k = 0;
    while(b)
    {
        bb[k] = b%2;
        k++;
        b /= 2;
    }
    long long s = 1;
    for(int i=k-1; i>=0; --i)
    {
        s = (s*s)%n;
        if(bb[i])
            s =(s*a)%n;
    }
    s %= n;
    if(s<0)
        s += n;
    return s;
}

把扩展最大公约数、模的线性方程和幂的模组合在一起使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值