hdu 1018

很久没A题。。。原来学过的都忘了……

很久以前的一个题,试着再A一遍也难了,物是人非啊……

复习一下吧!

 

 

Big Number

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6291    Accepted Submission(s): 2836

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

 

Sample Input
2
10
20
 

 

Sample Output
7
19
  题意就是求一个数阶乘的位数!
#include <stdio.h>
#include <math.h>
void main()
{
 int count,var,j;
 double sum;
 scanf("%d",&count);
 while(count--)
 {
  sum=0;
  scanf("%d",&var);
  for(j=1;j<=var;j++)
   sum+=log10(j);
  printf("%d/n",(int)sum+1);
 }
}
这是最简单的方法,但是耗时长,406ms。
好吧!我们换个方法:
这需要组合数学的知识。log10(n!) = log10(sqrt(2 * pi * n)) + n * log10(n / e)
Problem ID: 1018
Problem Title:
Run result: Accept
Run time:0MS
Run memory:332KB
//System Comment End//
#include <iostream>
#include <cmath>
#define PI 3.14159265
int n;
int num,ans;
void solve()
{
    double t;
    int i;
    t = (num*log(num) - num + 0.5*log(2*num*PI))/log(10);
    ans = t+1;
    printf("%d/n",ans);
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        while(n--)
        {
            scanf("%d",&num);
            solve();
        }
    }
    return 0;
}
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值