kuangbin专题五A题- Wireless Network POJ - 2236

 
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS

题意:刚开始 有 N 台坏掉的计算机 , 然后 距离相差不超过 d 的计算机(已经修复)之间可以 联系 。
   计算机 从 1 到 N 编号 , 之后 输入 N 台计算机 的位置 ,
   然后 有多组操作 O x (表示 编号为 x 的电脑被修复) ,S x y (表示 查询 电脑 x 和 电脑 y 之间能不能联系(包括直接联系和间接联系))
   可以联系 输出 SUCCESS , 不能联系 输出 FAIL
思路:并查集

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
#include <cmath>
using namespace std ; 

#define maxn 1010 
bool flag[maxn] ;
int father[maxn] ; 

vector<int> vv[maxn] ; 
int n , d ; 

struct node {
    int x , y ;
} post[maxn] ; 

double fun(int x){
    return x*x*1.0 ; 
}

void init(){
    memset(vv , 0 , sizeof(vv)) ; 

    for(int i=1 ; i<=n ; i++){
        father[i] = i ; //初始化 每台电脑为一个集合
        flag[i] = false ;// 所有电脑 初始状态为损坏 

        for(int j =1 ; j<=n ; j++){
            if(i==j){
                continue ; 
            }
            //为 i 电脑 链接 所有 可连接距离内的电脑
            double dis = sqrt(fun(post[i].x-post[j].x)+fun(post[i].y-post[j].y)) ; 
            if(dis<=d){
                vv[i].push_back(j) ; 
            }
        }
    }
}
//查询 x 所在集合的代表元素的编号
//同时 理顺集合内元素的关系(为刚合并的两个集合找出统一的代表)
int find(int x){
    if(x!=father[x])
        father[x] = find(father[x]) ; 
    return father[x] ; 
}

void Union_set(int x , int y){
    int rootx = find(x) ; 
    int rooty = find(y) ; 

    if(rootx != rooty){
        father[rooty] = rootx ; // 将 第二个集合的带表元素 连接到第一个集合 
    }
}



int main(){

    while(~scanf("%d %d" , &n , &d)){
        for(int i=1 ; i<=n ; i++){
            scanf("%d%d" , &post[i].x , &post[i].y) ; 
        }

        init() ; 
        char str[3] ; 
        int x , y ; 

        while(~scanf(" %s" , str)){
            //scanf(" %s" , str) ; 

            if(str[0] == 'O'){
                scanf("%d" , &x) ; 
                flag[x] = true ; 
                for(int j=0 ; j<vv[x].size() ; j++){
                    int k = vv[x][j] ; 
                    if(flag[k]){//编号为 k 的电脑已经被修复 
                        Union_set(x , k ) ; 
                    }
                }
            }else if(str[0] =='S'){
                scanf("%d %d" , &x , &y) ; 
                int rootx = find(x) ; 
                int rooty = find(y) ; 
                if(rootx == rooty){
                    printf("SUCCESS\n") ; 
                } else {
                    printf("FAIL\n") ; 
                }
            }
        }
        
    }
    return 0 ; 
}
View Code

 


转载于:https://www.cnblogs.com/yi-ye-zhi-qiu/p/7990384.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值