1014. Waiting in Line (30)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
Customer[i] will take T[i] minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am. 

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output “Sorry” instead.
Sample Input

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output

08:07
08:06
08:10
17:00
Sorry


1、若有窗口队伍没有排满,则选择队伍最短的窗口,进行入队
2、若所有窗口队伍已满,选择队首离开时间最早的窗口,进行出对入队。更新其队首用户离开时间。
3、当所有用户已经入队,进行出队处理,计算出所有用户的离队时间。


#include<iostream>
#include<queue>
#include<algorithm>
#include<vector>
using namespace std;
#define maxn 1010
#define INF 10000000
int n,m,k,q;
struct user{
    int intime,outtime,pt,w;
}pt[maxn];
struct windows{
    int num;
    queue<int> waiter;
}wd[25];

int findw(){//找到当前队伍最短窗口
    int t=-1,l=100;
    for(int i=0;i<n;i++){
        if(wd[i].waiter.size()<m){
            if(wd[i].waiter.size()<l){
                t=i;
                l=wd[i].waiter.size();
            }
        }
    }
    return t;
}
void allleave(){//所有人离队
    for(int i=0;i<n;i++){
        while(!wd[i].waiter.empty()){
            int le=wd[i].waiter.front();
            wd[i].waiter.pop();
            if(!wd[i].waiter.empty()){
                int k=wd[i].waiter.front();
                pt[k].intime=pt[le].outtime;
                pt[k].outtime=pt[k].intime+pt[k].pt;
            }
        }
    }
}
void init(){//初始化
    int cnt=1; 
    for(int j=0;j<n;j++){
        wd[j].waiter.push(cnt);
        cnt++;
        if(cnt>k) return;
    }
}
void leave(){//选择一个窗口离队
    int mint =INF,l,le;
    for(int i=0;i<n;i++){
        int k=wd[i].waiter.front();
        if(pt[k].outtime<mint){
            l=i;
            le=k;
            mint=pt[k].outtime;
        }
    }
    wd[l].waiter.pop();
    int k=wd[l].waiter.front();
    pt[k].intime=pt[le].outtime;
    pt[k].outtime=pt[k].intime+pt[k].pt;
}
int main(){
    scanf("%d%d%d%d",&n,&m,&k,&q);
    for(int i=0;i<n;i++)
        wd[i].num=i;
    for(int i=1;i<=k;i++){
        scanf("%d",&pt[i].pt);
    }
    int cnt=1;
    for(int i=1;i<=n&&i<=k;i++){
        pt[i].intime=8*60;
        pt[i].outtime=pt[i].intime+pt[i].pt;
        cnt++;
    }
    init();
    while(cnt<=k){
        int fw=findw();
        if(fw!=-1){
            wd[fw].waiter.push(cnt);
            pt[cnt].w=fw;
            cnt++;
        }
        else {
            leave();
        }
    }
    allleave();
    int t;
    for(int i=0;i<q;i++){
        scanf("%d",&t);
        if(pt[t].intime<17*60)
            printf("%02d:%02d\n",pt[t].outtime/60,pt[t].outtime%60);
        else printf("Sorry\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值