数据结构实验之二叉树的建立与遍历

数据结构实验之二叉树的建立与遍历

Time Limit: 1000MS Memory limit: 65536K

题目描述

       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。

输入

  输入一个长度小于50个字符的字符串。

输出

输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。

示例输入

abc,,de,g,,f,,,

示例输出

cbegdfa
cgefdba
3
5

 

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
typedef char telemtype;
typedef char status;
typedef struct BiTNode
{
    telemtype data;
    struct BiTNode *lchild, *rchild;
}*BiTree;

char c[55];
int i;
status create(BiTree &T)
{
    if(c[i++]==',') T=NULL;
    else
    {
        T = (BiTNode *) malloc (sizeof(BiTNode));
        if(!T) exit(0);
        T->data = c[i-1];
        create(T->lchild);
        create(T->rchild);
    }
    return 1;
}

void inorder(BiTree &T)
{
    if(T)
    {
        inorder(T->lchild);
        printf("%c", T->data);
        inorder(T->rchild);
    }
}

void postorder(BiTree &T)
{
    if(T)
    {
        postorder(T->lchild);
        postorder(T->rchild);
        printf("%c", T->data);
    }
}

void CountLeaf(BiTree T, int &count)
{
    if (T)
    {
        if ((!T->lchild)&&(!T->rchild))
            count++;
        CountLeaf(T->lchild, count);
        CountLeaf(T->rchild, count);
    }

}
int depth(BiTree T)
 {
     int ld, rd;
     if(!T) return 0;
     else
     {
         ld=depth(T->lchild);
         rd=depth(T->rchild);
         if(ld>rd)
             return ld+1;
         else
             return rd+1;
     }

 }
int main()
{
    BiTree T;
    while(~scanf("%s", c))
    {
        i=0;
        create(T);
        inorder(T);
        printf("\n");
        postorder(T);
        printf("\n");
        int count = 0;
        CountLeaf(T, count);
        printf("%d\n", count);
        printf("%d\n", depth(T));

    }
}


 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值