hdu 2126 Buy the souvenirs(求方案数)

   链接:hdu 2126

Problem Description
When the winter holiday comes, a lot of people will have a trip. Generally, there are a lot of souvenirs to sell, and sometimes the travelers will buy some ones with pleasure. Not only can they give the souvenirs to their friends and families as gifts, but also can the souvenirs leave them good recollections. All in all, the prices of souvenirs are not very dear, and the souvenirs are also very lovable and interesting. But the money the people have is under the control. They can’t buy a lot, but only a few. So after they admire all the souvenirs, they decide to buy some ones, and they have many combinations to select, but there are no two ones with the same kind in any combination. Now there is a blank written by the names and prices of the souvenirs, as a top coder all around the world, you should calculate how many selections you have, and any selection owns the most kinds of different souvenirs. For instance:



And you have only 7 RMB, this time you can select any combination with 3 kinds of souvenirs at most, so the selections of 3 kinds of souvenirs are ABC (6), ABD (7). But if you have 8 RMB, the selections with the most kinds of souvenirs are ABC (6), ABD (7), ACD (8), and if you have 10 RMB, there is only one selection with the most kinds of souvenirs to you: ABCD (10).
 

Input
For the first line, there is a T means the number cases, then T cases follow.
In each case, in the first line there are two integer n and m, n is the number of the souvenirs and m is the money you have. The second line contains n integers; each integer describes a kind of souvenir. 
All the numbers and results are in the range of 32-signed integer, and 0<=m<=500, 0<n<=30, t<=500, and the prices are all positive integers. There is a blank line between two cases.
 

Output
If you can buy some souvenirs, you should print the result with the same formation as “You have S selection(s) to buy with K kind(s) of souvenirs”, where the K means the most kinds of souvenirs you can buy, and S means the numbers of the combinations you can buy with the K kinds of souvenirs combination. But sometimes you can buy nothing, so you must print the result “Sorry, you can't buy anything.”
 

Sample Input
  
  
2 4 7 1 2 3 4 4 0 1 2 3 4
 

Sample Output
  
  
You have 2 selection(s) to buy with 3 kind(s) of souvenirs. Sorry, you can't buy anything.
 
题意:有n件物品,价格已知,旅客手上钱为m。问旅客最多可以买多少件物品及买最多物品的方案数。
分析:将所有的物品按照价值从小到大 排序 先买便宜的, 再买 贵的。贪心的思想。这样最多买多少物品很容易求。
              如果所有物品的价值总和比旅客的钱少,那么就只有一个方案,旅客可以买走所有的物品。
              如果旅客的钱数连最便宜的物品都买不起,那么就直接输出
               ” Sorry,you can't buy anything.“。
关键是怎样求方案数:我们用dp[j][k]表示花费j元买k件物品的方案数,
实际上很容易就可以得到dp[j][k]=dp[j][k]+dp[j-a[i]][k-1]。

AC代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int i,T,j,k,n,m,a[35],sum,s[510][35];
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        sum=0;
        for(i=1;i<=n;i++){
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        sort(a+1,a+1+n);
        if(m<a[1])
            printf("Sorry, you can't buy anything.\n");
        else if(m>=sum)
            printf("You have 1 selection(s) to buy with %d kind(s) of souvenirs.\n",n);
        else{
            sum=0;
            k=m;
            for(i=1;i<=n;i++){
                k-=a[i];
                if(k>=0)
                    sum++;
            }
            memset(s,0,sizeof(s));
            for(i=0;i<=m;i++)
                s[i][0]=1;
            for(i=1;i<=n;i++)
                for(j=m;j>=a[i];j--)
                    for(k=1;k<=sum;k++)
                        s[j][k]+=s[j-a[i]][k-1];
            printf("You have %d selection(s) to buy with %d kind(s) of souvenirs.\n",s[m][sum],sum);
        }
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值