hdu 5083 Instruction(模拟)

Instruction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 988    Accepted Submission(s): 241


Problem Description
Nowadays, Jim Green has produced a kind of computer called JG. In his computer, the instruction is represented by binary code. However when we code in this computer, we use some mnemonic symbols. For example, ADD R1, R2 means to add the number in register R1 and R2, then store the result to R1. But this instruction cannot be execute directly by computer, before this instruction is executed, it must be changed to binary code which can be executed by computer. Each instruction corresponds to a 16-bit binary code. The higher 6 bits indicates the operation code, the middle 5 bits indicates the destination operator, and the lower 5 bits indicates the source operator. You can see Form 1 for more details.
15 operation code(6 bits)109destination operator code(5 bits)54source operator code(5 bits)0Form 1


In JG system there are 6 instructions which are listed in Form 2.
instructionADD Ra,RbSUB Ra,RbDIV Ra,RbMUL Ra,RbMOVE Ra,RbSET RafunctionAdd the number in register Ra and Rb, then store the result to Ra.Subtract the number in register Ra to Rb, then store the result to Ra.Divide the number in register Ra by Rb, then store the result to Ra.Mulplicate the number in register Ra and Rb, then store the result to Ra.Move the number in register Rb to Ra.Set 0 to Ra.Form 2


Operation code is generated according to Form 3.
OperationADDSUBDIVMULMOVESETOperation code000001000010000011000100000101000110Form 3


Destination operator code and source operator code is the register code of the register which is related to.
There are 31 registers in total. Their names are R1,R2,R3…,R30,R31. The register code of Ri is the last 5 bits of the number of i in the binary system. For eaxample the register code of R1 is 00001, the register code of R2 is 00010, the register code of R7 is 00111, the register code of R10 is 01010, the register code of R31 is 11111.
So we can transfer an instruction into a 16-bit binary code easyly. For example, if we want to transfer the instruction ADD R1,R2, we know the operation is ADD whose operation code is 000001, destination operator code is 00001 which is the register code of R1, and source operator code is 00010 which is the register code of R2. So we joint them to get the 16-bit binary code which is 0000010000100010.
However for the instruction SET Ra, there is no source register, so we fill the lower 5 bits with five 0s. For example, the 16-bit binary code of SET R10 is 0001100101000000
You are expected to write a program to transfer an instruction into a 16-bit binary code or vice-versa.
 

Input
Multi test cases (about 50000), every case contains two lines.
First line contains a type sign, ‘0’ or ‘1’. 
‘1’ means you should transfer an instruction into a 16-bit binary code;
‘0’ means you should transfer a 16-bit binary code into an instruction.
For the second line.
If the type sign is ‘1’, an instruction will appear in the standard form which will be given in technical specification; 
Otherwise, a 16-bit binary code will appear instead.
Please process to the end of file.

[Technical Specification]
The standard form of instructions is 
ADD Ra,Rb
SUB Ra,Rb
DIV Ra,Rb
MUL Ra,Rb
MOVE Ra,Rb
SET Ra
which are also listed in the Form 2.
1a,b31
There is exactly one space after operation, and exactly one comma between Ra and Rb other than the instruction SET Ra. No other character will appear in the instruction.
 

Output
For type ‘0’,if the 16-bit binary code cannot be transferred into a instruction according to the description output “Error!” (without quote), otherwise transfer the 16-bit binary code into instruction and output the instruction in the standard form in a single line.
For type ‘1’, transfer the instruction into 16-bit binary code and output it in a single line.
 

Sample Input
  
  
1 ADD R1,R2 0 0000010000100010 0 1111111111111111
 

Sample Output
  
  
0000010000100010 ADD R1,R2 Error!
题意:1是把操作变成字符串,2是把字符串变成操作,字符串不合法就输出Error!

思路:直接模拟即可。注意坑:

1:1的情况SET要特别处理,要注意第二个字符串不要处理得数组越界了
2:0的情况 16进制字符串分成三个部分
第一部分只能是1~6,第二部分不能为0,第三部分当第一部分是6时必须为0
当第一部分不是6时不能为0
代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

int main()
{
    int n;
    char a[100],b[100];
    while(~scanf("%d",&n))
    {
        if(n)
        {
            scanf("%s",a);
            scanf("%s",b);
            if(strcmp(a,"SET")==0)
                printf("000110");
            else if(strcmp(a,"ADD")==0)
                printf("000001");
            else if(strcmp(a,"SUB")==0)
                printf("000010");
            else if(strcmp(a,"DIV")==0)
                printf("000011");
            else if(strcmp(a,"MUL")==0)
                printf("000100");
            else if(strcmp(a,"MOVE")==0)
                printf("000101");
            int s,len;
            if(strcmp(a,"SET")==0)
            {
                len=strlen(b);
                if(len<3) s=b[1]-'0';
                else s=(b[1]-'0')*10+b[2]-'0';
            }
            else
            {
                if(b[2]==',') s=b[1]-'0';
                else s=(b[1]-'0')*10+b[2]-'0';
            }
            for(int i=4; i>=0; i--)
            {
                if(s&(1<<i)) printf("1");
                else printf("0");
            }
            if(strcmp(a,"SET")==0)
                printf("00000");
            else
            {
                int t;
                len=strlen(b);
                if(b[len-2]=='R') t=b[len-1]-'0';
                else t=(b[len-2]-'0')*10+b[len-1]-'0';
                for(int i=4; i>=0; i--)
                {
                    if(t&(1<<i)) printf("1");
                    else printf("0");
                }
            }
            printf("\n");
        }
        else
        {
            scanf("%s",a);
            int sum=0;
            for(int i=0; i<6; i++)
                sum+=(a[i]-'0')*(1<<(5-i));
            int sum1=0;
            for(int i=6; i<11; i++)
                sum1+=(a[i]-'0')*(1<<(10-i));
            int sum2=0;
            for(int i=11; i<16; i++)
                sum2+=(a[i]-'0')*(1<<(15-i));
            if(sum==0||sum>6||sum1==0||(sum==6&&sum2!=0)||(sum!=6&&sum2==0))
            {
                printf("Error!\n");
                continue;
            }
            if(sum==1) printf("ADD R");
            else if(sum==2) printf("SUB R");
            else if(sum==3) printf("DIV R");
            else if(sum==4) printf("MUL R");
            else if(sum==5) printf("MOVE R");
            else if(sum==6) printf("SET R");
            printf("%d",sum1);
            if(sum!=6) printf(",R%d",sum2);
            printf("\n");
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值