poj 3169 Layout(差分约束,最短路)

Layout
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9960 Accepted: 4779

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
题意:在一条直线上有n头奶牛,奶牛可能站在同一个位置,奶牛之间有两种关系

1:关系好的奶牛想要相隔的距离不超过x

2:关系不好的牛奶想要像个的距离不小于x

现在问你从1号奶牛到n号奶牛最远距离是多少

如果不存在从1号奶牛到n号奶牛的距离,输出-1

如果距离是无限长,输出-2

否则输出最长距离

思路:差分约束的模板题,直接列出关系

x[t]-x[s]<=w

x[s]-x[t]<=-w

x[i]-x[i+1]<=0

然后跑一遍spfa即可

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 1050
#define INF 999999999
struct Edge
{
    int v,next,w;
}edge[N*20];
int cnt,head[N],n;
int d[N],vis[N],num[N];
void init()
{
    cnt=0;
    memset(head,-1,sizeof(head));
}
void addedge(int u,int v,int w)
{
    edge[cnt].v=v;edge[cnt].w=w;
    edge[cnt].next=head[u];
    head[u]=cnt++;
}
int spfa(int s)
{
    memset(vis,0,sizeof(vis));
    memset(num,0,sizeof(num));
    for(int i=1;i<=n;i++)
        d[i]=i==s?0:INF;
    vis[s]=1;
    queue<int>que;
    que.push(s);
    while(!que.empty())
    {
        int u=que.front();
        que.pop();
        vis[u]=0;
        num[u]++;
        if(num[u]>n) return -1;
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            int v=edge[i].v,w=edge[i].w;
            if(d[v]>d[u]+w)
            {
                d[v]=d[u]+w;
                if(!vis[v])
                {
                    vis[v]=1;
                    que.push(v);
                }
            }
        }
    }
    if(d[n]==INF) return -2;
    return d[n];
}
int main()
{
    int p,q;
    int s,t,w;
    while(~scanf("%d %d %d",&n,&p,&q))
    {
        init();
        for(int i=0;i<p;i++)
        {
            scanf("%d %d %d",&s,&t,&w);
            addedge(s,t,w);
        }
        for(int i=0;i<q;i++)
        {
            scanf("%d %d %d",&s,&t,&w);
            addedge(t,s,-w);
        }
        for(int i=2;i<=n;i++)
            addedge(i,i-1,0);
        printf("%d\n",spfa(1));
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值