HDU - 4112 Break the Chocolate

Problem Description

Benjamin is going to host a party for his big promotion coming up.
Every party needs candies, chocolates and beer, and of course Benjamin has prepared some of those. But as everyone likes to party, many more people showed up than he expected. The good news is that candies are enough. And for the beer, he only needs to buy some extra cups. The only problem is the chocolate.
As Benjamin is only a 'small court officer' with poor salary even after his promotion, he can not afford to buy extra chocolate. So he decides to break the chocolate cubes into smaller pieces so that everyone can have some.
He have two methods to break the chocolate. He can pick one piece of chocolate and break it into two pieces with bare hand, or put some pieces of chocolate together on the table and cut them with a knife at one time. You can assume that the knife is long enough to cut as many pieces of chocolate as he want.
The party is coming really soon and breaking the chocolate is not an easy job. He wants to know what is the minimum number of steps to break the chocolate into unit-size pieces (cubes of size 1 × 1 × 1). He is not sure whether he can find a knife or not, so he wants to know the answer for both situations.
 

Input
The first line contains an integer T(1<= T <=10000), indicating the number of test cases.
Each test case contains one line with three integers N,M,K(1 <=N,M,K <=2000), meaning the chocolate is a cube of size N ×M × K.
 

Output
For each test case in the input, print one line: "Case #X: A B", where X is the test case number (starting with 1) , A and B are the minimum numbers of steps to break the chocolate into N × M × K unit-size pieces with bare hands and knife respectively.
 

Sample Input
 
   
2 1 1 3 2 2 2
 

Sample Output
 
   
Case #1: 2 2 Case #2: 7 3
题意:给你立方体的巧克力,让你用手掰,和用刀切弄成1*1*1的小巧克力分别最少用多少,用刀切,能够无论有多少块

思路:掰的话,肯定要sum-1次,切的话。由于能够多块一起切。所以我们分别考虑长,宽,高,分别要多少次,才干切成小块。结果是log2(len),分别统计相加就是了

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
typedef long long ll;
using namespace std;

int main() {
	int t, n, m, k, cas = 1;
	scanf("%d", &t);
	while (t--) {
		scanf("%d%d%d", &n, &m, &k);
		ll ans = 1ll * n * m * k;
		int cnt = 0;
		cnt += ceil(1.0 * log(n) / log(2));
		cnt += ceil(1.0 * log(m) / log(2));
		cnt += ceil(1.0 * log(k) / log(2));
		printf("Case #%d: ", cas++);
		cout << ans-1 << " " << cnt << endl;;
	}
	return 0;
}




转载于:https://www.cnblogs.com/ljbguanli/p/6797148.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值