Electron Cloud

 

Electron Cloud

Time Limit: 2 Seconds      Memory Limit: 65536 KB

The electron is described in terms of its probability distribution or probability density. This probability distribution does not have definite cutoff points; its edges are somewhat fuzzy. Hence the term "electron cloud." This cloudy probability distribution takes on different shapes, depending on the state of the atom.

In order to describe a nuclear action, you are asked to tell where the electrons may occur.

Here we assume that the electrons only occur within a sphere whose location and radius are given. The action consists of only two atoms.

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases. (0 < T ≤ 50)

Each test case consists of a line containing 8 integers X1Y1Z1R1X2Y2Z2 and R2, describing the coordinates and the radiuses of the two atoms. The absolute value of each coordinate do not exceed 100 and 0 < R1R2 ≤ 100.

Output

For each test case, output the volume of space where the electrons may occur, accurated to the nearest 0.01.

Sample Input

 

0 0 0 1 0 0 2 1 
0 0 0 2 0 0 2 2 
0 0 0 2 0 0 2 1 

 

Sample Output

 

8.38 
56.55 
36.00

 

 Sample code:

 #include<stdio.h>

#include < math.h >
#define  PI acos(-1.0)
struct  point
{
     
double  x,y,z;
     
double  r;
}p1,p2;

double  dis(point a,point b)
{
     
return  sqrt((a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y) + (a.z - b.z) * (a.z - b.z));
}

double  V( double  r)
{
     
return  ( 4.0 / 3 ) * PI * r * r * r;
}

double  V2( double  r, double  h)
{
     
return  ( 2.0 / 3 ) * PI * r * r * h - ( 1.0 / 3 ) * PI * (r - h) * (r * r - (r - h) * (r - h));
}

void  swap( double   & a, double   & b)
{
     
double  t;
     t
= a;
     a
= b;
     b
= t;
}

void  volumn(point p1,point p2)
{
     
double  d = dis(p1,p2);
     
if (p1.r < p2.r) swap(p1.r,p2.r);
     
if (p1.r + p2.r <= d)
       printf(
" %.2f\n " ,V(p1.r) + V(p2.r));
     
else   if (d <= p1.r - p2.r)
       printf(
" %.2f " ,V(p1.r));
     
else
     {
          
double  r1 = p1.r,r2 = p2.r;
          
double  t = (r1 * r1 - r2 * r2) / d;
          
double  h1 = (d + t) / 2 ;
          
double  h2 = (d - t) / 2 ;
          h1
= (r1 - h1);
          h2
= (r2 - h2);
          
double  ans = V(p1.r) + V(p2.r) - V2(p1.r,h1) - V2(p2.r,h2);
          printf(
" %.2f\n " ,ans);
        }
}

int  main()
{
     
int  n;
     scanf(
" %d " , & n);
     
while (n -- )
     {
          scanf(
" %lf%lf%lf%lf " , & p1.x, & p1.y, & p1.z, & p1.r);
          scanf(
" %lf%lf%lf%lf " , & p2.x, & p2.y, & p2.z, & p2.r);
          volumn(p1,p2);
        }
     
return   0 ;

} 

 

转载于:https://www.cnblogs.com/cpoint/archive/2011/05/19/2051275.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值