杭电oj(java版)——1093 A+B for Input-Output Practice (V)

这篇博客主要介绍了如何使用Java解决杭电在线评测系统(OJ)中的A+B问题,作为输入输出的练习。通过实例展示了如何读取输入并进行简单的加法运算,然后输出结果。
摘要由CSDN通过智能技术生成

A+B for Input-Output Practice (V)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 77072    Accepted Submission(s): 51478


Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
 

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
 

Sample Input
  
  
2 4 1 2 3 4 5 1 2 3 4 5
 

Sample Output
  
  
10

15

import java.util.Scanner;

public class Main{
	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		int n = scanner.nextInt();
		
		for (int i=0;i<n;i++) {
			int len = scanner.nextInt();
			int sum = 0;
			
			for (int j=0;j<len;j++) {
				sum += scanner.nextInt();
			}
			System.out.println(sum);
		}		
	}	
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值