杭电oj(Java版)——1260 Tickets

Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4144    Accepted Submission(s): 2092


Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
 

Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
 

Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
 

Sample Input
  
  
2 2 20 25 40 1 8
 

Sample Output
  
  
08:00:40 am 08:00:08 am
 
import java.util.Scanner;

public class Main{
	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		int n = scanner.nextInt();	//有几组数据
		for (int i=0;i<n;i++) {
			int p = scanner.nextInt();	//	有几个人
			int arr[] = new int[p+1];	//每个人单独需要的时间
			int brr[] = new int[p+1];	//相邻两个人所需的世界
			int dp[] = new int[p+1];
			for (int j=1;j<=p;j++) {
				arr[j] = scanner.nextInt();	//每个人各自需要的时间
			}
			
			for (int j=2;j<=p;j++) {
				brr[j] = scanner.nextInt();
			}
			dp[1] = arr[1];
			
			for (int j=2;j<=p;j++) {
				dp[j] = Math.min(dp[j-1]+arr[j], dp[j-2]+brr[j]);
			}
			
			int h,m,s;	//时分秒
			h = (dp[p]/3600+8)%24;
			String hh = f(h);
			
			m = dp[p]%3600/60;
			String mm = f(m);
			
			s = dp[p]%60;
			String ss = f(s);
			System.out.println((hh+":"+mm+":"+ss+" ")+((h)>12?"pm":"am"));
		}
	}

	private static String f(int h) {
		if (h<10) {
			return "0"+h;
		}else {
			return h+"";
		}
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值