Winter-2-STL-G Team Queue 解题报告及测试数据

Time Limit:3000MS     Memory Limit:0KB

Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.

Input

The input file will contain one or more test cases. Each test case begins with the number of teams t (  1=< t <= 1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue

DEQUEUE - process the first element and remove it from the queue

STOP - end of test case

The input will be terminated by a value of 0 for t.

Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

Output

For each test case, first print a line saying `` Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

Sample Input

2

3 101 102 103

3 201 202 203

ENQUEUE 101

ENQUEUE 201

ENQUEUE 102

ENQUEUE 202

ENQUEUE 103

ENQUEUE 203

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

STOP

2

5 259001 259002 259003 259004 259005

6 260001 260002 260003 260004 260005 260006

ENQUEUE 259001

ENQUEUE 260001

ENQUEUE 259002

ENQUEUE 259003

ENQUEUE 259004

ENQUEUE 259005

DEQUEUE

DEQUEUE

ENQUEUE 260002

ENQUEUE 260003

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

STOP

0

Sample Output

Scenario #1

101

102

103

201

202

203

 

Scenario #2

259001

259002

259003

259004

259005

260001

题解:

  1. 可以理解为大队列中的多个小队列,大队列只需要记录小队列队号的顺序。小队列记录相应的人的顺序。

  2. 进队操作时,由于时间复杂度需要,对应数字所在的小队队号则直接映射为数组的值,数组开得足够大即可。 

  3. 人进队时,若该小队已经有人,那么直接进入该小队即可,如果该小队是空的,进入该小队后,还应当将小队队号排进大队列,即大队列进行入队操作。

  4. ​出队也一样,先从大队列中获取站在最前面的小队的队号,出队后,如果该小队人出完了,就要从大队列中将该小队的队号去掉,即大队列进行 出队操作。

以下是代码:

 

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cctype>
#include <queue>
using namespace std;
queue<int>q[1005];
queue<int>qq;
int tag[1000005];//储存输入数字所在的队team
void init(){
    for(int i=0;i<1000005;tag[i]=-1,i++);
    while(!qq.empty())qq.pop();
    for(int i=0;i<1005;i++)
        while(!q[i].empty())q[i].pop();
}
int main()
{
    //freopen("1.in","r",stdin);
    int n,tn,t;
    int cnt = 0;
    char str[100];
    while(scanf("%d",&n)!=EOF && n){
        init();
        for(int i=0;i<n;i++){
            scanf("%d",&tn);
            while(tn--){
                scanf("%d",&t);
                tag[t]=i;
            }
        }
        printf("Scenario #%d\n",++cnt);
        while(scanf("%s",str)!=EOF && str[0]!='S'){
            if(str[0]=='E'){//若该小队为空,则将小队号op入队,否则直接进入所在的小队
                scanf("%d",&t);
                int op = tag[t];
                if(q[op].empty())qq.push(op);
                q[op].push(t);
            }else{
    //出队时,先从大队获取队首,及最前面的小队号,该小队内的人出队
    //若出队后为空,则将队号从大队出队。
                int num = qq.front();
                printf("%d\n",q[num].front());
                q[num].pop();
                if(q[num].empty())qq.pop();
            }
        }
        printf("\n");
    }
}

  

 

转载于:https://www.cnblogs.com/gzdaijie/p/4298982.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值