Is It A Tree?

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

上午刚刚写完并查集的随笔,没想到下午就用上,心里美滋滋啊。但是这道题我也错了很多,他和一般的并查集不一样在于他查找的话,你需要找一个数组进行标记,因为他不是那种连续性查找,所以还是给大家提个醒。首先是数据的录入要注意第一组数据,其次还得注意数组清零,接下来还得注意for循环的范围,刚开始我统计输入的次数,然后循环来做,wa6次,然后我崩溃了就直接拿10000来怼,然后就过了。神奇吧,话不多说贴代码,如果看不懂这个并查集,你可以看一下我的随笔(https://blog.csdn.net/aini875/article/details/81505762)有介绍,并且我发现他和那个小希的迷宫一样,就是改一下输出。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 100000
using namespace std;
int pre[N+10],n,m,book[N+10];
void chushihua()
{
    memset(book,0,sizeof(book));
    for(int i=0; i<=N; i++)
        pre[i]=i;
    return ;
}
int find1(int x)
{
    int r=x;
    while(pre[r]!=r)
        r=pre[r];
    int i=x,j ;
    while(i!=r)
    {
        j=pre[i];
        pre[i]= r ;
        i=j;
    }
    return r ;

}
void join(int x,int y)
{
    int fx=find1(x);
    int fy=find1(y);
    if(fx!=fy)
        pre[fx]=fy;
}
int main()
{
    int w=1;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==-1&&m==-1)
            break;
        chushihua();
        int flag=0;
        while(n+m)
        {
            if(find1(n)==find1(m))
                flag=1;
            join(n,m);
            book[n]=1;
            book[m]=1;
            scanf("%d%d",&n,&m);
        }
        if(flag)
            printf("Case %d is not a tree.\n",w++);
        else
        {
            int ans=0;
            for(int i=0; i<=N; i++)
                if(book[i]&&pre[i]==i)
                    ans++;
            if(ans>1)printf("Case %d is not a tree.\n",w++);
            else printf("Case %d is a tree.\n",w++);
        }
    }
    return 0;
}
 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值