Goldbach`s Conjecture

Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

  1. Both a and b are prime
  2. a + b = n
  3. a ≤ b

Sample Input

2

6

4

Sample Output

Case 1: 1

Case 2: 1

题意:其实很简单,就是用质数满足他提出的要求,重点就是你控制数据不超时,不然就会很难受。

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 10000010
int a[700005];
bool book[N]= {0};
void cn()
{
    int z = 0;
    book[0] = book[1] = 1;
    for (int i = 2; i < N; i++)
    {
        if (!book[i])
        {
            a[z++] = i;
            for (int j = 2*i; j < N; j += i)
                book[j] = 1;
        }
    }
}
int main()
{
    int T,k=1;
    cn();
    scanf("%d", &T);
    while (T--)
    {
        int x,ans=0;
        scanf("%d", &x);
        for (int i = 0; 2*a[i] <= x; i++)
        {
            if (!book[x - a[i]]) ans++;
        }
        printf("%s%d: %d\n", "Case ", k++, ans);

    }
    return 0;
}
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值