Rightmost Digit

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) 
Total Submission(s): 56655 Accepted Submission(s): 21400

Problem Description 
Given a positive integer N, you should output the most right digit of N^N.

Input 
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output 
For each test case, you should output the rightmost digit of N^N.

Sample Input 


4

Sample Output 

6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. 
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6. 
解题思路:本题有规律可寻个位数相乘mod10会出现循环

if (ans == 0 || ans == 1 || ans == 5 || ans == 6)
return ans;
if (ans == 2 || ans == 3 || ans == 7 || ans == 8)
// T = 4
if (ans == 4 || ans == 9)
// T = 2

具体实现

#include <stdio.h>

int main()
{
int num;
scanf("%d",&num);
while(num--){
long long value;
scanf("%lld",&value);
int ans = value % 10;
if (ans == 0 || ans == 1 || ans == 5 || ans == 6)
printf("%d\n",ans);
else
{
int a[10][10] = {0};
for (int i = 2; i < 10; ++i){
int k = 1;
for (int j = 1; j < 10; ++j){
k *= i;
a[i][j] = k%10;
}
}
if (ans == 4 || ans == 9)
printf("%d\n",a[ans][value % 2 + 2]);
else
printf("%d\n",a[ans][value % 4 + 4]);
}
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值