字典比较,下一排列组合,上一排列组合

题目描述:

输入一个字符串,按字典序打印出该字符串中字符的所有排列。例如输入字符串abc,则打印出由字符a,b,c所能排列出来的所有字符串abc,acb,bac,bca,cab和cba。

输入:

每个测试案例包括1行。

输入一个字符串,长度不超过9(可能有字符重复),字符只包括大小写字母。

输出:

对应每组数据,按字典序输出所有排列。

样例输入:
abc BCA 
样例输出:
abc acb bac bca cab cba ABC ACB BAC BCA CAB CBA

#include <iostream>
#include <string>
#include <stdio.h>
#include <algorithm>

using namespace std;

int main()
{
    string str;
    while(cin>>str)
    {
        sort(str.begin(),str.end());
        string tmp(str);
        do
        {
            //cout<<tmp<<endl;
            printf("%s\n",tmp.c_str());  //用printf()纯粹是为了提高打印速度.
            /*
            next_permutation(tmp.begin(),tmp.end());下一排列组合.
            prev_permutation(tmp.begin(),tmp.end());上一排列组合.

            */
            next_permutation(tmp.begin(),tmp.end());
        }while(lexicographical_compare(str.begin(),str.end(),tmp.begin(),tmp.end()));
        //字典比较.
    }
    return 0;
}

转载于:https://www.cnblogs.com/wmx3ng/archive/2012/09/13/2775955.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值