POJ 3276 Face The Right Way(反转)

Face The Right Way
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions:5977 Accepted: 2757

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than Kcows, e.g., at the either end of the line of cows). Each cow remains in the same *location* as before, but ends up facing the *opposite direction*. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer:  N 
Lines 2.. N+1: Line  i+1 contains a single character,  F or  B, indicating whether cow  i is facing forward or backward.

Output

Line 1: Two space-separated integers:  K and  M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

Hint

For  K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)
代码:

#include<cstdio>
#include<iostream>
#include<string.h>
using namespace std;
const int maxn=5000+5;
int f[maxn];//i~i+k-1是否进行 反转操作
int dir[maxn];//牛的初始方向
int main()
{
    int n,i,j;scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        char t;cin>>t;
        if(t=='B')dir[i]=0;
        else dir[i]=1;
    }
    int K=1,M=n;//最多n次操作
    for(int k=1;k<=n;k++)
    {
        int sum=0,res=0; memset(f,0,sizeof(f));
        for(i=0;i+k-1<n;i++)
        {
            if(i-k>=0)
                sum-=f[i-k];//i-k前的操作对i不影响
            if((dir[i]+sum)%2==0)//牛朝后,要反转
            {
                res++;//操作数+1
                f[i]=1;
            }
            sum+=f[i];
        }
        for( ;i<n;i++)//检查剩下的牛是否满足条件
        {
            sum-=f[i-k];
            if((dir[i]+sum)%2==0)
                res=-1;
        }
        if(res!=-1&&res<M)
            M=res,K=k;
    }
    printf("%d %d\n",K,M);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值