HDU 1394 Minimum Inversion Number

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22542    Accepted Submission(s): 13419


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
 
 
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
 
 
16
 

开始满足条件的若有sum个,则把t从第一个移到最后一个后,逆序数
减少了t个,增加了n-t-1个,因此,此时的sum=sum-t+n-t-1;
因为n在5000以内,因此可以O(n*n)求解。
如果数据在扩大,则可以线段树求解。

暴力求解:

#include<bits/stdc++.h>
using namespace std;
const int maxn=5009;
int a[maxn];
int main()
{
    int n,m,i,j;
    while(~scanf("%d",&n))
    {
        int sum=0,ans;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            for(j=1;j<i;j++)
                if(a[j]>a[i])sum++;
        }
        ans=sum;
        for(i=1;i<=n;i++)
        {
            sum=sum-a[i]+(n-a[i]-1);
            ans=min(ans,sum);
        }
        printf("%d\n",ans);
    }
    return 0;
}

线段树求解:

#include<bits/stdc++.h>
using namespace std;
const int maxn=5009;
int a[maxn],s[maxn<<2];
int query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&R>=r)return s[rt];
    int m=(l+r)>>1;
    int ans=0;
    if(L<=m) ans+=query(L,R,l,m,rt<<1);
    if(R>m)ans+=query(L,R,m+1,r,rt<<1|1);
    return ans;
}
void update(int L,int l,int r,int rt)
{
    if(l==r)
    {
        s[rt]++;
        return;
    }
    int m=(l+r)>>1;
    if(L<=m) update(L,l,m,rt<<1);
    else update(L,m+1,r,rt<<1|1);
    s[rt]=s[rt<<1]+s[rt<<1|1];
}
int main()
{
    int n,m,i,j;
    while(~scanf("%d",&n))
    {
        memset(s,0,sizeof(s));
        int sum=0,ans;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum+=query(a[i]+1,n,1,n,1);
            //查询a[i]+1~n中已存在的个数。
            update(a[i],1,n,1);//更新个数。
        }
        ans=sum;
        for(i=1;i<=n;i++)
        {
            sum=sum-a[i]+(n-a[i]-1);
            ans=min(ans,sum);
        }
        printf("%d\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值