HDU 2147 kiki's game(巴什博弈)

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/10000 K (Java/Others)
Total Submission(s): 12354    Accepted Submission(s): 7509


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input
 
 
5 3 5 4 6 6 0 0
 

Sample Output
 
 
What a pity! Wonderful! Wonderful!

题解:
有两堆石子,一次可以从其中一堆取出一个,也可以同时从
两堆中各取一个,最后取完者获胜。巴什博弈的原型。
n,m只要有一个为偶数则先手赢。
#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        if(!(n%2)||!(m%2))printf("Wonderful!\n");
        else printf("What a pity!\n");
    }
    return 0;
}


开始不知道这是巴什博弈就自己打了个表但是样例都不能过,不知道为什么。
如有过路大神还请指教:


#include<bits/stdc++.h>
using namespace std;
bool dp[2002][2002];
int main()
{
    for(int i=0;i<2002;i++)
    {
        if(i%2==1)dp[0][i]=dp[i][0]=1;
        else dp[0][i]=dp[i][0]=0;
    }
    for(int i=1;i<6;i++)
    {
        for(int j=1;j<6;j++)
        {
            if(!dp[i-1][j]||!dp[i][j-1]||!dp[i-1][j-1])
                dp[i][j]=1;
        }
    }
    int n,m;
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        if(!dp[n][m])printf("What a pity!\n");
        else printf("Wonderful!\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值