POJ 1741 Tree(树上点分治)

Tree
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 28073 Accepted: 9355

Description

Give a tree with n vertices,each edge has a length(positive integer less than 1001). 
Define dist(u,v)=The min distance between node u and v. 
Give an integer k,for every pair (u,v) of vertices is called valid if and only if dist(u,v) not exceed k. 
Write a program that will count how many pairs which are valid for a given tree. 

Input

The input contains several test cases. The first line of each test case contains two integers n, k. (n<=10000) The following n-1 lines each contains three integers u,v,l, which means there is an edge between node u and v of length l. 
The last test case is followed by two zeros. 

Output

For each test case output the answer on a single line.

Sample Input

5 4
1 2 3
1 3 1
1 4 2
3 5 1
0 0

Sample Output

8

#include<cstdio>
#include<string.h>
#include<algorithm>
#include<vector>
using namespace std;
const int maxn=10004;
struct node
{
    int to,cost;
};
vector<node>G[maxn];
vector<int>dep;
int n,k,root,son[maxn],f[maxn],len,ans,vis[maxn],d[maxn];
void getroot(int v,int fa)//找树的重心
{
    f[v]=son[v]=0;
    for(int i=0;i<G[v].size();i++)
    {
        node e=G[v][i];
        if(e.to==fa||vis[e.to])continue;
        getroot(e.to,v);
        son[v]+=son[e.to]+1;
        f[v]=max(f[v],son[e.to]+1);
    }
    f[v]=max(f[v],len-son[v]-1);
    if(f[v]<f[root])
        root=v;
}
void getdep(int st,int fa)
{
    dep.push_back(d[st]);
    for(int i=0;i<G[st].size();i++)
    {
        node e=G[st][i];
        if(e.to==fa||vis[e.to])continue;
        d[e.to]=d[st]+e.cost;
        getdep(e.to,st);
    }
}
int cal(int st,int cost)
{
    dep.clear();
    d[st]=cost;
    getdep(st,0);
    sort(dep.begin(),dep.end());
    int res=0,l=0,r=dep.size()-1;
    while(r>l)
    {
        if(dep[r]+dep[l]<=k)
            res=res+r-l,l++;
        else r--;
    }
    return res;
}
void work(int st)
{
    ans+=cal(st,0);
    vis[st]=1;
    for(int i=0;i<G[st].size();i++)
    {
        node e=G[st][i];
        if(vis[e.to])continue;
        ans-=cal(e.to,e.cost);//去重
        root=0;f[0]=len=son[e.to]+1;
        getroot(e.to,0);
        work(root);
    }
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        if(n==0&&k==0)break;
        ans=0;
        for(int i=0;i<=n;i++)
            G[i].clear();
        memset(vis,0,sizeof(vis));
        for(int i=1;i<n;i++)
        {
            int x,y,z;scanf("%d%d%d",&x,&y,&z);
            G[x].push_back((node){y,z});
            G[y].push_back((node){x,z});
        }
        len=n;f[0]=n;
        getroot(1,root=0);
        work(root);
        printf("%d\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值