hdu 1814 Peaceful Commission (2-sat)

Peaceful Commission

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5202    Accepted Submission(s): 1660


Problem Description
The Public Peace Commission should be legislated in Parliament of The Democratic Republic of Byteland according to The Very Important Law. Unfortunately one of the obstacles is the fact that some deputies do not get on with some others. 

The Commission has to fulfill the following conditions: 
1.Each party has exactly one representative in the Commission, 
2.If two deputies do not like each other, they cannot both belong to the Commission. 

Each party has exactly two deputies in the Parliament. All of them are numbered from 1 to 2n. Deputies with numbers 2i-1 and 2i belong to the i-th party . 

Task 
Write a program, which: 
1.reads from the text file SPO.IN the number of parties and the pairs of deputies that are not on friendly terms, 
2.decides whether it is possible to establish the Commission, and if so, proposes the list of members, 
3.writes the result in the text file SPO.OUT. 
 

Input
In the first line of the text file SPO.IN there are two non-negative integers n and m. They denote respectively: the number of parties, 1 <= n <= 8000, and the number of pairs of deputies, who do not like each other, 0 <= m <=2 0000. In each of the following m lines there is written one pair of integers a and b, 1 <= a < b <= 2n, separated by a single space. It means that the deputies a and b do not like each other. 
There are multiple test cases. Process to end of file. 
 

Output
The text file SPO.OUT should contain one word NIE (means NO in Polish), if the setting up of the Commission is impossible. In case when setting up of the Commission is possible the file SPO.OUT should contain n integers from the interval from 1 to 2n, written in the ascending order, indicating numbers of deputies who can form the Commission. Each of these numbers should be written in a separate line. If the Commission can be formed in various ways, your program may write mininum number sequence. 
 

Sample Input
 
 
3 2 1 3 2 4
 

Sample Output
 
 
1 4

5

思路:
2-sat,建边,暴力搜索每一种情况。
代码:
#include<bits/stdc++.h>
using namespace std;
const int maxn=20005;
vector<int>G[maxn];
int n,m,col[maxn],cnt,k[maxn];
int other(int x)
{
    if(x&1)
        return x+1;
    else
        return x-1;
}
bool have_try(int v)
{
    if(col[v])
        return col[v]%2;
    col[v]=1;
    col[other(v)]=2;
    k[cnt++]=v;
    for(int i=0; i<G[v].size(); i++)
    {
        if(!have_try(G[v][i]))
            return 0;
    }
    return 1;
}
bool work()
{
    memset(col,0,sizeof(col));
    for(int i=1; i<=2*n; i++)
    {
        if(col[i])
            continue;
        cnt=0;
        if(!have_try(i))
        {
            for(int j=0; j<cnt; j++)
                col[k[j]]=col[other(k[j])]=0;
            if(!have_try(other(i)))
                return 0;
        }
    }
    return 1;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0; i<maxn; i++)
            G[i].clear();
        while(m--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            G[x].push_back(other(y));
            G[y].push_back(other(x));
        }
        if(work())
        {
            for(int i=1; i<=2*n; i++)
                if(col[i]==1)
                    printf("%d\n",i);
        }
        else
            printf("NIE\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值