hdu3949 XOR xor高斯消元

XOR

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1364    Accepted Submission(s): 402


Problem Description
XOR is a kind of bit operator, we define that as follow: for two binary base number A and B, let C=A XOR B, then for each bit of C, we can get its value by check the digit of corresponding position in A and B. And for each digit, 1 XOR 1 = 0, 1 XOR 0 = 1, 0 XOR 1 = 1, 0 XOR 0 = 0. And we simply write this operator as ^, like 3 ^ 1 = 2,4 ^ 3 = 7. XOR is an amazing operator and this is a question about XOR. We can choose several numbers and do XOR operatorion to them one by one, then we get another number. For example, if we choose 2,3 and 4, we can get 2^3^4=5. Now, you are given N numbers, and you can choose some of them(even a single number) to do XOR on them, and you can get many different numbers. Now I want you tell me which number is the K-th smallest number among them.
 

 

Input
First line of the input is a single integer T(T<=30), indicates there are T test cases.
For each test case, the first line is an integer N(1<=N<=10000), the number of numbers below. The second line contains N integers (each number is between 1 and 10^18). The third line is a number Q(1<=Q<=10000), the number of queries. The fourth line contains Q numbers(each number is between 1 and 10^18) K1,K2,......KQ.
 

 

Output
For each test case,first output Case #C: in a single line,C means the number of the test case which is from 1 to T. Then for each query, you should output a single line contains the Ki-th smallest number in them, if there are less than Ki different numbers, output -1.
 

 

Sample Input
2 2 1 2 4 1 2 3 4 3 1 2 3 5 1 2 3 4 5
 

 

Sample Output
Case #1: 1 2 3 -1 Case #2: 0 1 2 3 -1
Hint
If you choose a single number, the result you get is the number you choose. Using long long instead of int because of the result may exceed 2^31-1.
 

 

Author
elfness
 

 

Source
 

 

Recommend
xubiao   |   We have carefully selected several similar problems for you:   3946  3948  3947  3945  3944 
 
  這道題調的心絞痛,最後發現在hdu上不能用#ifdef 來定義%I64d,真心無語啊,#ifdef WIN32 在hdu上卦,#ifdef unix 在tyvj上卦,以後估計網上刷題不敢再用了。
  在來說一下這道題的正解吧,xor有一個重要性質,即一個數被xor兩邊後不變。本題中有一大堆數字,a1,a2,...,an,對於數列中的ai,aj,我們將ai改爲ai xor aj,結果不變,於是我們可以通過類似於高斯消元的方法,將序列去重,可以證明,去重後的數列項數少於等於62。而在消元時,我們是從高位向低位消成倒三角模式(注意,其中並不涉及矩陣操作),在消去的數列中,如果有0則實際能夠組成的數集中含有0,反之不含,這裏需要特判一下。接下來由於高位優先原則,我們可以用一個簡單的貪心logn解決詢問。
 
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<ctime>
#include<cmath>
#include<algorithm>
#include<set>
#include<map>
#include<vector>
#include<string>
#include<queue>
#include<stack>
using namespace std;
#ifdef WIN32
#define LL "%I64d"
#else
#define LL "%lld"
#endif
#define MAXN 110000
typedef long long qword;
void pm(int x)
{
        for (int i=5;i>=0;i--)
                printf("%d",(x&(1ll<<i))!=0);
        printf("\n");
}
qword num[MAXN];
int n,m;
int main()
{
        //freopen("input.txt","r",stdin);
        //freopen("output.txt","w",stdout);
        int i,j,k;
        int x,y,z;
        int n;
        int nn;
        bool flag;
        scanf("%d",&nn);
        int testid=0;
        while (testid++,nn--)
        {
                printf("Case #%d:\n",testid);
                scanf("%d",&n);
                for (i=0;i<n;i++)
                {
                        scanf(LL,&num[i]);
                }
                int now=0;
        //        for (i=0;i<n;i++)pm(num[i]);
                for (i=0;i<n;i++)
                {
                        for (j=now+1;j<n;j++)
                        {
                                if (num[j]>num[now])swap(num[j],num[now]);
                        }
                        if (!num[now])break;
                        for (x=63;!(num[now]&(1ll<<x));x--);
                        for (j=now+1;j<n;j++)
                        {
                                if (num[j]&(1ll<<x))
                                        num[j]^=num[now];
                        }
                        now++;
                }
                //for (i=0;i<n;i++)pm(num[i]);printf("\n");
                flag=false;
                for (i=0;i<n;i++)
                        if (!num[i])flag=true;
                scanf("%d",&m);
                qword rk;
                qword ans=0;
                int pos;
                for (i=0;i<m;i++)
                {
                        scanf(LL ,&rk);
                        if (!flag)rk++;
                        ans=0;
                        rk--;
                        pos=now-1;
                        if (rk>=(1ll<<now))
                        {
                                printf("-1\n");
                                continue;
                        }
                        for (pos=63;!(num[0]&(1ll<<pos));pos--);
                        for (j=now-1;j>=0;j--)
                        {
                                while (pos>0 && !(num[now-j-1]&(1ll<<pos)))pos--;
                                if (rk&(1ll<<j))
                                {
                                        if (!(ans&(1ll<<pos)))
                                                ans^=num[now-j-1];
                                }else
                                {
                                        if (ans&(1ll<<pos))
                                                ans^=num[now-j-1];
                                }
                        }
                        /*
                        qword l=0,r=(1ll<<now);
                        qword mid;
                        for (i=0;i<now;i++)
                        {
                                if (!(ans&(1<<i)))
                                {
                                        mid=l+(1<<(now-i-1));
                                }
                        }*/
                        printf(LL "\n",ans);
                }
        }
        return 0;
}

 

 

转载于:https://www.cnblogs.com/mhy12345/p/3970592.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值