(PAT)N Queens Puzzle(N皇后改版)

The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing Nnon-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q​1​​,Q​2​​,⋯,Q​N​​), where Q​i​​ is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.

8q.jpg 9q.jpg
Figure 1 Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format "N Q​1​​ Q​2​​... Q​N​​", where 4≤N≤1000 and it is guaranteed that 1≤Q​i​​≤N for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

我的解题思路:

由于给出了每个皇后的位置,所以我们可以从第一列开始对每个皇后进行递推,如果它的右侧行,上斜线,下斜线出现了另一个皇后,那么我们判定这不是N皇后

读入皇后坐标并在矩阵上标记为1,然后递推每一个皇后

#include <iostream>
#include <vector>
using namespace std;
const int maxn = 201;
int chessBorad[maxn][maxn];
vector<bool> res;
bool flag = true;

int main() {
	memset(chessBorad, 0, sizeof(chessBorad));
	int n;
	cin >> n;
	for (int i = 0; i < n; ++i) {
		int N;
		cin >> N;
		int a[200];
		for (int j = 1; j <= N; ++j) {
			int num = 0;
			cin >> num;
			a[j] = num;
			chessBorad[N - num + 1][j] = 1;
		}
		for (int i = 1; i < N; ++i) {   //每个皇后
			for (int j = 1; j <= N-i; ++j) {   //每个皇后距离右边界的距离
					if (chessBorad[N - a[i] + 1][i + j] == 1)     //向右递推
					{
						flag = false;
						break;
					}
					if (N - a[i] + 1 + j >= 1 && N - a[i] + 1 + j <= N && chessBorad[N - a[i] + 1 + j][i + j] == 1)  //斜向上递推
					{
						flag = false;
						break;
					}
					if (N - a[i] + 1 - j >= 1 && N - a[i] + 1 - j <= N && chessBorad[N - a[i] + 1 - j][i + j] == 1)  //斜向下递推
					{
						flag = false;
						break;
					}
			}
			if (flag == false) {
				break;
			}
		}
		res.push_back(flag);
		flag = true;
		memset(chessBorad, 0, sizeof(chessBorad));
	}

	for (auto x : res) {
		if (x) {
			cout << "YES" << endl;
		}
		else {
			cout << "NO" << endl;
		}
	}
	system("PAUSE");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值