(PAT 1044)Shopping in Mars (二分法lower_bound)

1044 Shopping in Mars (25 分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5​​), the total number of diamonds on the chain, and M (≤10​8​​), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​⋯D​N​​ (D​i​​≤10​3​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

解题思路:

这题做了好久才做出来

因为是取中间某一段数列的和,所以可以把数列按段加起来

这样就得到一串单调递增的数列,由于是有序的,我们可以考虑使用二分法防止超时

依然是从数组中最小的元素开始遍历,每遍历一个元素,使用二分法查找在数列中是否有对应的元素使该 元素+对应元素>=目标和

对于测试用例2中的情况,我们可以使用lower_bound,找到第一个大于目标和的元素(那就是最小的),我们建立一个vector用来保存即可。

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
const int MAXN = 100010;
int des[MAXN];
int Dimonds[MAXN];
int N, M;

int lowerBound(int i, long long x) {
	int mid;
	int left = i + 1, right = N;
	while (left < right) {
		mid = (left + right) / 2;
		if (Dimonds[mid] - Dimonds[i] >= x) {
			right = mid;
		}
		else {
			left = mid + 1;
		}
	}
	des[i] = right;  //将左下标保存到数组中
	return Dimonds[right] - Dimonds[i];  //返回子段的和
}

int main() {
	scanf("%d %d", &N, &M);
	Dimonds[0] = 0;
	for (int i = 1; i <= N; ++i) {
		int num;
		scanf("%d", &num);
		Dimonds[i] = Dimonds[i - 1] + num;
	}
	long long MM = 9999999999;
	vector<int> res;
	for (int i = 0; i < N; ++i) {
		int sha = lowerBound(i, (long long)M);  
		if (sha >= M) {
			if (sha == MM) {    //如果存在等同于MM的数列和,则将下标保存
				res.push_back(i);
			}
			else if(sha < MM) {
				res.clear();    //否则,清空vector,保存更小的下标和
				res.push_back(i);
				MM = sha;
			}
		}
		else {
			break;
		}
	}

	for (int i = 0; i < res.size(); ++i) {
		printf("%d-%d\n", res[i]+1, des[res[i]]);
	}

	system("PAUSE");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值