Nunit 2.6 无法调试.Net Framework 4.0

好久没有写单元测试了,拿出来一个原来的单元测试在跑,突然发现断点加载不上了,查了一下,说是要修改nunit.exe.config

[html] view plaincopyprint?
<configuration>  
  <!--  
   The GUI only runs under .NET 2.0 or higher. The  
   useLegacyV2RuntimeActivationPolicy setting only  
   applies under .NET 4.0 and permits use of mixed   
   mode assemblies, which would otherwise not load   
   correctly这里面必须去掉version 2.0 的设置  
   -->   
<startup useLegacyV2RuntimeActivationPolicy="true">  
    <requiredRuntime version="v4.0.30319" />  
    <supportedRuntime version="v4.0.30319" />  
  </startup>  
  <runtime>  
    <!-- Ensure that test exceptions don't crash NUnit -->  
    <legacyUnhandledExceptionPolicy enabled="1" />  
  
  
    <!-- Run partial trust V2 assemblies in full trust under .NET 4.0 -->  
    <loadFromRemoteSources enabled="true" />  
      
    <!-- Look for addins in the addins directory for now -->  
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">  
      <probing privatePath="lib;addins" />  
    </assemblyBinding>  
  </runtime>  
</configuration>  

ok,可以了,如果你想要看framework 版本号,可以直接输入%systemroot%\Microsoft.NET\Framework


©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页