HDU A Mathematical Curiosity



A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32001    Accepted Submission(s): 10253


Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input
      
      
1 10 1 20 3 30 4 0 0
 

Sample Output
      
      
Case 1: 2 Case 2: 4 Case 3: 5
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1013  1018  1008  1016  1005 
 

#include<iostream>
#include<cstdio>
using namespace std;

int main()
{
    int i,N,n,m,a,b,k,w;
    while(cin>>N)
    {
        for(i=1; i<=N; i++)
        {
            if(i>1)//接下来的空白的一行紧跟的是N个输入块!!两个输入块之间才有一个空行...第一个输入块没有空行
                cout<<endl;
                w=0;
            while(cin>>n>>m&&(n!=0||m!=0))
            {
                k=0;
                for(a=1; a<n-1; a++)
                {
                    for(b=a+1; b<n; b++)
                    {
                        if(((a*a+b*b+m)%(a*b))==0)
                            k++;
                    }
                }
                w++;
                cout<<"Case "<<w<<": "<<k<<endl;

            }
        }
    }
    return 0;
}


 
    


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值