Eclipse 安装Maven 错误总结

第一中错误:

           错误信息如下:

        org.slf4j.api 1.6.2' but it could not be found
  Missing requirement: Maven Integration for Eclipse 1.4.0.20130601-0317 (org.eclipse.m2e.core.ui 1.4.0.20130601-0317) requires 'bundle org.slf4j.api 1.6.2' but it could not be found
  Cannot satisfy dependency:
    From: Maven Integration for Eclipse 1.4.1.20140328-1905 (org.eclipse.m2e.core.ui 1.4.1.20140328-1905)
    To: bundle org.eclipse.m2e.core [1.4.0,1.5.0)
  Cannot satisfy dependency:
    From: m2e logback appender 1.4.1.20140328-1905 (org.eclipse.m2e.logback.appender 1.4.1.20140328-1905)
    To: bundle org.eclipse.m2e.core.ui [1.4.0,1.5.0)
  Cannot satisfy dependency:
    From: m2e - slf4j over logback logging (Optional) 1.4.1.20140328-1905 (org.eclipse.m2e.logback.feature.feature.group 1.4.1.20140328-1905)
    To: org.eclipse.m2e.logback.appender [1.4.1.20140328-1905]
主要原因是因为没有找到    org.slf4j.api 1.6.2

因此首先安装这个插件,步骤如下:

           1.help --->Install new software 的workwith中输入如下网址:http://www.fuin.org/p2-repository/   然后会等一会儿,接下就是下一步,下一步。

            2.当安装完成后, 进入Maven的安装步骤,具体步骤 大同小异,网上都能收到。


第二种错误:

    错误信息如下:

            Missing requirement: Maven Integration for Eclipse 1.4.0.20130601-0317 (org.eclipse.m2e.core.ui 1.4.0.20130601-0317) requires 'bundle org.slf4j.api 1.6.2' but it could not be found
  Cannot satisfy dependency:
    From: Maven Integration for Eclipse 1.4.1.20140328-1905 (org.eclipse.m2e.core.ui 1.4.1.20140328-1905)
    To: bundle org.eclipse.m2e.core [1.4.0,1.5.0)
  Cannot satisfy dependency:
    From: m2e logback appender 1.4.1.20140328-1905 (org.eclipse.m2e.logback.appender 1.4.1.20140328-1905)
    To: bundle org.eclipse.m2e.core.ui [1.4.0,1.5.0)
  Cannot satisfy dependency:
    From: m2e - slf4j over logback logging (Optional) 1.4.1.20140328-1905 (org.eclipse.m2e.logback.feature.feature.group 1.4.1.20140328-1905)
    To: org.eclipse.m2e.logback.appender [1.4.1.20140328-1905]


解决办法:


      启动eclipse,点击window——>preferences——>install/update——>available software sites,点击Add
    添加如下信息:
     GEF  http://download.eclipse.org/tools/gef/updates/releases/


然后接着进行 maven 的安装


©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页