华硕a豆安装ubuntu14.04系统开启wifi

笔记本新安装的ubuntu系统无法找到WIFI列表,原因是没有安装无线网卡的驱动文件,导致无法识别WIFI信号

需要安装对应网卡的驱动文件,网卡型号可以在windows10系统的桌面点击"此电脑 / 属性 / 设备管理器",打开设备管理器,查看“网络适配器”来查看无线网卡类型,例如我的华硕a豆笔记本自带的无线网卡是intel 8265,如图所示:

下载驱动:

可以通过链接https://wireless.wiki.kernel.org/en/users/Drivers/iwlwifi下载相应的驱动。

Intel® Wireless-AC 82654.6+iwlmvmiwlwifi-8265-ucode-22.361476.0.tgz

安装指令为(下面指令需要解压文件并进入解压文件夹):

cp iwlwifi-*.ucode /lib/firmware

驱动明确说明了需要的内核版本是4.6+,即最低需要4.6的kernel版本。

查看当前系统的内核版本:

当前系统自带的内核版本是4.4.0,所以需要升级内核版本。

通过以下网址下载需要的内核版本:

按版本号升序排列:

https://kernel.ubuntu.com/~kernel-ppa/mainline/

按版本号降序排列:

https://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D

 

也可以按照直接下载下面的4.10.14版本的内核,在ubuntu14.04上可以正常使用。

升级内核:

You could certainly reinstall and use 17.04 instead of 16.04. You could also download and install the 4.10-xx kernel and required firmware. If you'd prefer to do the latter, then I assume that your installation is 64-bit; confirm:

arch

If the terminal returns x86_64 then yours is a 64-bit install. Download the files to your desktop:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.10.14/linux-headers-4.10.14-041014_4.10.14-041014.201705031501_all.deb

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.10.14/linux-headers-4.10.14-041014-generic_4.10.14-041014.201705031501_amd64.deb

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.10.14/linux-image-4.10.14-041014-generic_4.10.14-041014.201705031501_amd64.deb

Install them all from the terminal:

cd ~/Desktop
sudo dpkg -i *.deb

Reboot and tell us if your wireless is working.

可以通过以上命令行安装也可以直接双击 deb 文件通过ubuntu软件中心安装。

安装完内核后重启就可以正常识别到 WIFI 信号了:)

 

本文参考以下三篇文章,感谢:

https://blog.csdn.net/linzhineng44/article/details/78778143

https://blog.csdn.net/photon222/article/details/89217488

https://askubuntu.com/questions/910934/intel-wifi-card-not-recognised-in-ubuntu-16-04

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页