PAT A1016 Phone Bills (25)

题目描述
A long-distance telephone company charges its customers by the following rules:
Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.
输入格式
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.
The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.
The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.
For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.
输出格式
For each test case, you must print a phone bill for each customer.
Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.
输入样例

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

输出样例

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

《算法笔记》中AC答案

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1010;
int toll[25];   //资费
struct Record {
    char name[25];      //姓名
    int month, dd, hh, mm;  //月份,日,时,分
    bool status;    //status==true表示该记录为on-line, 否则为off-line
} rec[maxn], temp;

bool cmp(Record a, Record b) {
    /*  strcmp(str1, str2)
    如果返回值 < 0,则表示 str1 小于 str2。
    如果返回值 > 0,则表示 str2 小于 str1。
    如果返回值 = 0,则表示 str1 等于 str2。
    */
    int s = strcmp(a.name, b.name);
    if(s != 0) return s < 0;    //优先按姓名字典序从小到大排序
    else if(a.month != b.month) return a.month < b.month;   //按月份从小到大排序
    else if(a.dd != b.dd) return a.dd < b.dd;               //按日期从小到大排序
    else if(a.hh != b.hh) return a.hh < b.hh;               //按小时从小到大排序
    else return a.mm < b.mm;                                //按分钟从小到大排序
}

void get_ans(int on, int off, int& time, int& money) {
    temp = rec[on];
    while(temp.dd < rec[off].dd || temp.hh < rec[off].hh || temp.mm < rec[off].mm) {
        time++;     //该记录总时间加1min
        money += toll[temp.hh]; //话费增加toll[temp.hh]
        temp.mm++;  //当前时间加1min
        if(temp.mm >= 60) { //当前时间书到达60
            temp.mm = 0;    //进入下一个小时
            temp.hh++;
        }
        if(temp.hh >= 24) { //当前小时数到达24
            temp.hh = 0;
            temp.dd++;
        }
    }
}

int main() {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif // ONLINE_JUDGE
    for(int i = 0; i < 24; i++) {
        scanf("%d", &toll[i]); //资费
    }
    int n;
    scanf("%d", &n);    //记录数
    char line[10]; //临时存放on-line或off-line的输入
    for(int i = 0; i < n; i++) {
        scanf("%s", rec[i].name);
        scanf("%d:%d:%d:%d", &rec[i].month, &rec[i].dd, &rec[i].hh, &rec[i].mm);
        scanf("%s", line);
        if(strcmp(line, "on-line") == 0) {
            rec[i].status = true;   //如果是on-line,则令status为true
        } else {
            rec[i].status = false;  //如果是off-line,则令status为false
        }
    }
    sort(rec, rec + n, cmp);    //排序
    int on = 0, off, next;      //on和off为配对的两条记录,next为下一个用户
    while(on < n) {             //每次循环处理单个用户的所有记录
        int needPrint = 0;      //needPrint表示该用户的所有记录
        next = on;              //从当前位置开始寻找下一个用户
        while(next < n && strcmp(rec[next].name, rec[on].name) == 0) {
            if(needPrint == 0 && rec[next].status == true) {
                needPrint = 1;  //找到on,置needPrint为1
            } else if(needPrint == 1 && rec[next].status == false) {
                needPrint = 2;  //在on之后如果找到off,置needPrint为2
            }
            next++;             //next自增,直到找到不同名字,即下一个用户
        }
        if(needPrint < 2) {     //没有找到配对的on-off
            on = next;
            continue;
        }
        int AllMoney = 0;       //总共花费的钱
        printf("%s %02d\n", rec[on].name, rec[on].month);
        while(on < next) {      //寻找该用户的所有配对
            while(on < next - 1
                  && !(rec[on].status == true && rec[on + 1].status == false)) {
                  on++;         //直到找到连续的on-line和off-line
                  }
            off = on + 1;       //off必须是on的下一个
            if(off == next) {   //以及输出完毕所有配对的on-line和off-line
                on = next;
                break;
            }
            printf("%02d:%02d:%02d ", rec[on].dd, rec[on].hh, rec[on].mm);
            printf("%02d:%02d:%02d ", rec[off].dd, rec[off].hh, rec[off].mm);
            int time = 0, money = 0;        //时间,单次记录花费的钱
            get_ans(on, off, time, money);  //计算on到off内的时间和金钱
            AllMoney += money;              //总金额加上该次记录的钱
            printf("%d $ %.2f\n", time, money / 100.0);
            on = off + 1;   //完成一个配对,从off+1开始找下一对
        }
        printf("Total amount:$%.2f\n", AllMoney / 100.0);
    }
    return 0;
}

转载于:https://www.cnblogs.com/isChenJY/p/11510033.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值