PAT A1148 Werewolf - Simple Version (20 分)

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5). Then N lines follow and the i-th line gives the statement of the i-th player (1), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences [ and [, if there exists 0 such that [ (ik) and [, then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

 

题意:N个玩家,两个狼人,两个说谎者,至少一个狼但不是所有的狼在说谎。输出两个说谎者的序号,如果不唯一,输出最小的。

分析:v 数组存放每个玩家说的话,双重循环分别假设 i,j 是狼人,然后遍历数组,如果k说的话和假设情况不同(不同号),判定为假话,存入lier数组,如果lier长度为2 且 只有一个狼人说假话,那么输出结果。

 

#include <bits/stdc++.h>
using namespace std;
int main (void){
    int N;
    cin >> N;
    vector <int> v(N+1);
    for (int i = 1; i <= N; i++){
        cin >> v[i];
    }
    for (int i = 1; i <= N; i++){
        for (int j = i + 1; j <= N; j++){
            vector <int> lier, a(N + 1, 1);
            a[i] = -1;
            a[j] = -1;
            for (int k = 1; k <= N; k++)
                if (v[k] * a[abs(v[k])] < 0){
                    lier.push_back(k);
                }
                if (lier.size() == 2 && a[lier[0]] + a[lier[1]] == 0){
                    cout << i << " " << j;
                    return 0;
                }
            
        }
    }
    cout << "No Solution";

    return 0;
}

 

 

 

  

 

转载于:https://www.cnblogs.com/yellowzunzhi/p/11112656.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值