POJ2115C Looooops(拓展欧几里得)

C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20702 Accepted: 5596

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER


题意:求解最小的y使得 A + C*y = B (mod 1<<k)。


思路:化简等式 (1<<k)*x + y*C = B-A。当且仅当(B-A) % gcd(1<<k, C) == 0才有解。

令temp = (B-A)/gcd(1<<k, C);

化简——(1<<k)*x/temp + y*C/temp = gcd(1<<k, C);

求出x和y,y *= temp。(这里可以求出x,y的值)


由扩展欧几里得 定理三——若gcd(a, b) = d,则方程ax ≡ c (mod b)在[0, b/d - 1]上有唯一解。


求解最小的y时,只需对(1<<k) / gcd(1<<k, C)取余即可。



AC代码:

#include <cstdio>  
#include <cstring>  
#include <algorithm>  
#define LL long long  
using namespace std;  
LL A, B, C, k;  
void exgcd(LL a, LL b, LL &d, LL &x, LL &y)  //拓展欧几里得求最小整数解
{  
    if(b == 0) {d = a, x = 1, y = 0;}  
    else  
    {  
        exgcd(b, a%b, d, y, x);  
        y -= x * (a / b);  
    }  
}  
void solve()  
{  
    B -= A;  
    LL d, x, y;  
    LL a = (1LL<<k);  
    exgcd(a, C, d, x, y);  
    if(B % d)  
        printf("FOREVER\n");  
    else  
    {  
        x *= (B / d); y *= (B / d);  
        y = (y % (a / d) + a / d) % (a / d);  
        printf("%lld\n", y);  
    }  
}  
int main()  
{  
    while(scanf("%lld%lld%lld%lld", &A, &B, &C, &k) != EOF)  
    {  
        if(A == 0 && B == 0 && C == 0 && k == 0)  
            break;  
        solve();  
    }  
    return 0;  
}  

什么叫欧几里得算法:

int gcd(int a,int b){  //求a,b的最大公约数gcd(a,b)
    return b?gcd(b,a%b):a;
}


什么叫拓展欧几里得算法,即欧几里得算法的扩展:

对于不完全为 0 的非负整数 a,b,gcd(a,b)表示 a,b 的最大公约数,必然
存在整数对 x,y ,使得 gcd(a,b)=ax+by。

1:带返回值的:

int gcd(int a,int b,int &x,int &y){
    if (b==0){
        x=1,y=0;
        return a;
    }
    int q=gcd(b,a%b,y,x);
    y-=a/b*x;
    return q;
}

2:不带返回值的:d是最大公倍数,x=1,y=-1

void exgcd(LL a, LL b, LL &d, LL &x, LL &y)
{
    if(b == 0) {d = a, x = 1, y = 0;}
    else
    {
        exgcd(b, a%b, d, y, x);
        y -= x * (a / b);
    }
}

#include<stdio.h>
#include<string.h>
#define LL long long
LL e_gcd(LL a,LL b,LL &x,LL &y)
{
    if(b==0)
    {
        x=1;
        y=0;
        return a;
    }
    LL ans=e_gcd(b,a%b,x,y);
    LL temp=x;
    x=y;
    y=temp-a/b*y;
    return ans;
}
LL cal(LL a,LL b,LL c)
{
    LL x,y;
    LL gcd=e_gcd(a,b,x,y);
    printf("_gcd:%I64d\n",e_gcd(a,b,x,y));
    printf("c:%I64d  %I64d\n",c,c%gcd);
    if(c%gcd!=0) 	
        return -1;
    x*=c/gcd;//转化为a*x+b*y=c的解
    b/=gcd;//约去c后原来b就变为了b/gcd;
    if(b<0) 
        b=-b;//如果b为负数就去绝对值
    LL ans=x%b;
    if(ans<=0) 
        ans+=b;//求最小正整数解
    return ans;//返回的就是最小正整数解
}
int main()
{
    LL a=12,b=9,x,y,c;
   // printf("%I64d  %I64d  %I64d  %I64d  %I64d\n",e_gcd(a,b,x,y),a,b,x,y);
    printf("%I64d\n",cal(a,b,c));
    return 0;
}


 




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值