zhexiao

keep going

PHP动态库php_mcrypt.dll和php_openssl.dll无法加载的问题

我在winXP底下安装的Apache2.2.2和PHP5.2.6。
每次启动Apache的时候,总是报php_mcrypt.dll和php_openssl.dll两个动态库加载失败的错误,即:
PHP Startup: Unable to load dynamic library 'C:\\php\\ext\\php_mcrypt.dll'
PHP Startup: Unable to load dynamic library 'C:\\php\\ext\\php_openssl.dll'
在网上搜索了半天,说啥的都有,但总也没个确切的办法。
倒是注意到其中一个文档说,php_mcrypt.dll要依赖libmcrypt.dll,于是就把libmcrypt.dll移动到了System32目录下面。
再启动Apache,呵呵~~居然真的只剩下php_openssl.dll的报错了。
受到启发后,再把php_openssl.dll的支持库libeay32.dll和ssleay32.dll也移动到System32下面,
终于完全搞定了~~~
阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/andybegin/article/details/7412616
个人分类: PHP
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭