*HDU 1237 栈

简单计算器

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19060    Accepted Submission(s): 6711


Problem Description
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
 

 

Input
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。
 

 

Output
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
 

 

Sample Input
1 + 2 4 + 2 * 5 - 7 / 11 0
 

 

Sample Output
3.00 13.36
 

 

Source
 

 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1230 1235 1234 1236 1229

模拟计算

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<stack>
using namespace std;
int main()
{
    char ch[420];
    while(gets(ch)&&strcmp(ch,"0"))
    {
        stack<char>s;
        stack<double>n;
        for(int i=0;ch[i];i++)
        {
            if(ch[i]>='0'&&ch[i]<='9')
            {
                double tem=0;
                while(ch[i]>='0'&&ch[i]<='9')
                {
                    tem=tem*10+ch[i]-'0';
                    i++;
                }
                i--;
                n.push(tem);
            }
            else if(ch[i]=='+'||ch[i]=='-')
            {
                if(!s.empty())
                {
                    char c=s.top();
                    s.pop();
                    double x1=n.top();
                    n.pop();
                    double x2=n.top();
                    n.pop();
                    if(c=='+')
                        x2+=x1;
                    else x2-=x1;
                    n.push(x2);
                }
                s.push(ch[i]);
            }
            else if(ch[i]=='*'||ch[i]=='/')
            {
                double x1=n.top();
                n.pop();
                double x2=0;
                int j=i;
                i+=2;
                while(ch[i]>='0'&&ch[i]<='9')
                {
                    x2=x2*10+ch[i]-'0';
                    i++;
                }
                i--;
                if(ch[j]=='*')
                    x1*=x2;
                else x1/=x2;
                n.push(x1);
            }
        }
        while(!s.empty())
        {
            char c=s.top();
            s.pop();
            double x1=n.top();
            n.pop();
            double x2=n.top();
            n.pop();
            if(c=='+')
                x2+=x1;
            else x2-=x1;
            n.push(x2);
        }
        printf("%.2lf\n",n.top());
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/--ZHIYUAN/p/6143048.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值